Inventory Agent causing the Symantec Management Agent to crash on Win x64 client - InvProvider.dll - Data class HW Chassis

Article:TECH180475  |  Created: 2012-02-01  |  Updated: 2012-09-05  |  Article URL http://www.symantec.com/docs/TECH180475
Article Type
Technical Solution


Issue



Inventory Agent causing the Symantec Management Agent to crash on Win x64 client - InvProvider.dll - Data class HW Chassis.

This issue is also occuring on Win 7 32 bit machines and has the same error message which causes Symantec Management Agent to crash. Applications logs shows the faulty path for InvProvider.dll.

This issue is also occuring on Win XP 32 bit machines and has the same error message which causes Symantec Management Agent to crash. Applications logs shows the faulty path for InvProvider.dll.


Error



Faulting application name: AeXNSAgentHostSurrogate32.exe, version:
7.1.8280.15280, time stamp: 0x4ec27200
Faulting module name: InvProvider.dll, version: 7.1.7580.0, time stamp:
0x4ec928df
Exception code: 0xc0000005
Fault offset: 0x00079f7f
Faulting process id: 0x1788
Faulting application start time: 0x01ccd1eea1c35a43
Faulting application path: C:\Program Files\Altiris\Altiris Agent\x86
\AeXNSAgentHostSurrogate32.exe
Faulting module path: C:\Program Files (x86)\Altiris\Altiris
Agent\Agents\Inventory Agent\InvProvider.dll
Report Id: 92f2d548-3de3-11e1-a113-001fd04654e2
 

Environment



Inventory Solution 7.1 SP2


Cause



This is a known issue, the HW Chassis data class causes this issue.


Solution



A point-fix is available for this issue. Please contact Symantec Support to obtain the new file.

Note that you can work around the issue by disabling collection of the HW Chassis data class under the Advanced setting of an Inventory Policy.

Take the following steps to deploy the InvProvider.dll provided in the point fix at the client machine:-
1. Stop the Symantec Management Agent from services.
2. Go to following location from “C:\Program Files (x86)\Altiris\Altiris Agent\Agents\Inventory Agent” on 64 bit system or “C:\Program Files\Altiris\Altiris Agent\Agents\Inventory Agent” on 32 bit system and unregister the InvProvider.dll by executing the following command on ‘Run’ command (Run as Admin):
For 64 bit machine:
regsvr32 /u "C:\Program Files\Altiris\Altiris Agent\Agents\Inventory Agent\InvProvider.dll"
For 32 bit machine:
regsvr32 /u "C:\Program Files\Altiris\Altiris Agent\Agents\Inventory Agent\InvProvider.dll"
3. Take the back of the original InvProvider.dll from “C:\Program Files (x86)\Altiris\Altiris Agent\Agents\Inventory Agent” or “C:\Program Files\Altiris\Altiris Agent\Agents\Inventory Agent” and copy the new InvProvider.dll at the same location.
4. Register the new InvProvider.dll by executing the following command on ‘Run’ command:
For 64 bit machine:
regsvr32 “C:\ Program Files (x86)\Altiris\Altiris Agent\Agents\Inventory Agent\InvProvider.dll
For 32 bit machine:
regsvr32 “C:\ Program Files\Altiris\Altiris Agent\Agents\Inventory Agent\InvProvider.dll
5. Restart the Symantec Management Agent.
6. Now Run Inventory policy or task to verify the point fix

Once verified, create a Software Management Task or Job to do this via script.


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Article URL http://www.symantec.com/docs/TECH180475


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