Unable to push out the Inventory Plug-in for Windows

Article:TECH180513  |  Created: 2012-02-01  |  Updated: 2012-02-15  |  Article URL http://www.symantec.com/docs/TECH180513
Article Type
Technical Solution


Issue



You are unable to push out the Inventory Plug-in for Windows after installing SMP 7.1 SP2. When enabling the policy to push this plugin out to the Symantec Management Agents an error occurs in the logs.


Error



 

Altiris.NS.Exceptions.AeXException: Unable to build the client configuration XML for advertisement with guid Inventory Plug-in Install (badabaac-2382-4e92-90a8-f933b64bc17b).
Reason: Unable to build the client configuration XML for advertisement with guid Inventory Plug-in for Windows  Install (1d04c3ce-0957-462e-9ea3-9938600ebd7b).
Reason: Did not get a row for Software Delivery Advertisement "Inventory Plug-in for Windows Install", Guid = Inventory Plug-in for Windows Install 

 

(1d04c3ce-0957-462e-9ea3-9938600ebd7b) from the SWD tables.

 

 

 


Environment



 Symantec Management Platform 7.1 SP2


Cause



The Inventory Plug-in for Windows package had gotten corrupted, which conseqently stopped the policy from creating the required XML.


Solution



1) Download the attached XML file, remove the .txt extension and copy it into the following location: 

\%InstallDir%\Program Files\Altiris\Notification Server\Bin\Tools\

2) Open up command prompt and change into the above mentioned directory and then execute the following command:

importexportutil.exe /import “<package file name.xml>”

3) Once the above command completes successfully, open up the Symantec Management Console and navigate to Manage -> Software and search the catalog for for the appropriate package name. Find the appropriate package name and double-click it to open it in edit mode.

Note: The affected packages may also be found in the Symantec Management Console by navigating to Manage -> All Resources, expanding All Resources and clicking on Software Component. Then, find the appropraite package name listed below, right-click on the package name and select Actions -> Edit Software Resource.

4) Select the Package tab. Note whether the command-lines are associated with the restored package.

5) If the command lines are not associated with the restored package, open up each command-line in edit mode and under the checkbox Command-line requires a package use the dropdown to select the restored package. Save the changes on each command-line.

6While still editing the package, select the Package Tab and click the entry listed under "Packages", click the edit button and browse/navigate to the correct location of the package.

7) Save the changes and close the window.

8) To finalize the changes made above and to ensure that the package has been properly distributed to any site servers you will need to run the NS.Package Distribution Point Update Schedule from Task Scheduler

 

Please note the following package names and default locations: 

Package File Name:          Inventory Plug-in for Windows Package.xml.txt    
Package name in console:  Inventory Plug-in for Windows 7.1.7580.0 - English (United States)
Default package location:  C:\Program Files\Altiris\Notification Server\NSCap\bin\Win32\X86\Inventory\Agent Package

Package File Name:          Server Inventory Plug-in for Windows Package.xml.txt
Package name in console:  Server Inventory Plug-in for Windows 7.1.7580.0 - English (United States)
Default package location:  C:\Program Files\Altiris\Notification Server\NSCap\bin\Win32\X86\Server Inventory\Agent Package

NOTE: If the Symantec Management Platform installed on a drive other than C, modify the package location to point to the correct drive and path. 

 




Article URL http://www.symantec.com/docs/TECH180513


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