Installation Error: The configuration data for this product is corrupt.

Article:TECH181371  |  Created: 2012-02-13  |  Updated: 2012-02-14  |  Article URL http://www.symantec.com/docs/TECH181371
Article Type
Technical Solution



Issue



Following a service pack update through liveupdate or a re-install of Backup Exec System Recovery(BESR), the system returns an error, ' The configuration data for this product is corrupt '


Error



Log Name: Application

Source: MsiInstaller

Event ID: 1002

Task Category: None

Level: Error

Keywords: Classic

Description:

Unexpected or missing value (name: 'PackageName', value: '') in key 'HKLM\Software\Classes\Installer\Products\55A8AE8AEBDF57845B89DD1CB5922809\SourceList'


Cause



This issue may be seen when some registry entries related to Backup Exec System Recovery are corrupt.


Solution



Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.

1. Navigate to the following registry path:

HKEY_LOCAL_MACHINE\Software\Classes\Installer\Products\55A8AE8AEBDF57845B89DD1CB5922809\SourceList

2. Verify if the PackageName registry key has a REG_SZ type and a Data value of Symantec System Recovery.msi

3. Also verify that the LastUsedSource registry key has a REG_EXPAND_SZ type and a Data value of a local path to the *.msi(For Example: n;1;D:\INSTALL\)

4. If the issue still persist then, delete the following registry key and re-run the installation.

HKEY_LOCAL_MACHINE\Software\Classes\Installer\Products\55A8AE8AEBDF57845B89DD1CB5922809





Article URL http://www.symantec.com/docs/TECH181371


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