PureDisk GUI has certificate error in IE8

Article:TECH181952  |  Created: 2012-02-22  |  Updated: 2012-02-22  |  Article URL http://www.symantec.com/docs/TECH181952
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution


Environment

Subject

Issue



When first accessing the PureDisk GUI from a browser, a user receives a message that the certificate is invalid. Some browsers like Internet Explorer recommend that the user immediately leave the site. Upon installing the certificate supplied by the SPA, most browsers no longer complain, but Internet Explorer continues to display a 'Certificate Error' in the browser window to the right of the address bar where otherwise the 'lock' icon would appear.


Cause



PureDisk relies upon VxAT services for authentication, a closed system security manager. VxAT does not trust anyone outside or above it as CA chain of trust would require.


Solution



Using a different browser than Internet Explorer allows installing the internal certificate and subsequent warnings disappear.

In the future VxAT may be modified to allow for external CA, allowing customers to purchase a certificate from Verisign to install on their PureDisk servers.




Article URL http://www.symantec.com/docs/TECH181952


Terms of use for this information are found in Legal Notices