Installing NetBackup 7.5 client on to a 64-bit Windows server running postgreSQL fails.

Article:TECH182539  |  Created: 2012-02-28  |  Updated: 2014-02-18  |  Article URL http://www.symantec.com/docs/TECH182539
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution


Issue



When attempting to install the NetBackup 7.5 client on to a 64-bit Windows server running postgreSQL, a popup error is displayed:  "PostgreSQL is already installed on this machine.  Uninstall the existing PostgreSQL and retry this setup."


Error



From the NetBackup install log:

02-21-2012,14:08:37 : ERROR: PostgreSQL is already installed on this machine. Uninstall the existing PostgreSQL and retry this setup. 

Environment



64-bit Windows 2008 R2 server.


Cause



The PostgreSQL validation check should not be active in the client installers. There was a bug where the check existed in the NetBackup 7.5 x64 client package.

The check is executed during server installations, and that is by design, it is to prevent installation of 7.5 servers in cases where PostgreSQL already exists.  In case the above error is received, make sure a client package is being installed, and not a server package.

 


Solution



This issue is resolved in version 7.5.0.3 and above.  An upgrade to 7.5.0.7 is recommended after applying the following engineering binary (EEB) to complete the initial 7.5 install:

Symantec Bug ID: ET2696992

Version:  NetBackup_7.5

Installation Location:  Installation Media

Installation Instructions: 

Replace the GA version of "Symantec NetBackup Client.msi" file in <MEDIA_ROOT>\PC_Clnt\x64 with the version provided in this EEB. That will disable the PostgreSQL check in the client installers.

Re-run the installation.

Note: If you are trying to install Netbackup Media Server you would need to first install the client binaries. Once the client binaries are installed then proceed with the installation of the server binaries. If you directly try to install the Netbackup Media Server binaries the installation will still fail.

So the steps would be as follows:

1. Replace the GA version of "Symantec NetBackup Client.msi" file in <MEDIA_ROOT>\PC_Clnt\x64 with the version provided in TECH182539
2. Install Netbackup 7.5 client
3. Install Netbackup 7.5 Media Server on top of the client.


Package Contents:

Please choose the appropriate platform after download:

Symantec NetBackup Client.msi    Windows x64 Installation

 

Symantec Corporation has acknowledged that the above-mentioned issue (ETrack 2697067) is present in the current version(s) of the product(s) mentioned in this article.  Symantec Corporation is committed to product quality and satisfied customers.  This issue was resolved in version 7.5.0.3.

Please note that Symantec Corporation reserves the right to remove any fix from a targeted release if it does not pass quality assurance tests or introduces new risks to overall code stability.  Symantec Corporation's plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.


Attachments

NB_7.5_ET2696992_1.zip is a hotfix for NetBackup 7.5 Installation media
NB_7.5_ET2696992_1.zip (37.5 MBytes)

Supplemental Materials

SourceETrack
Value2697067
Description

Customer is trying to install the NetBackup client software to a host which has postgreSQL installed.





Article URL http://www.symantec.com/docs/TECH182539


Terms of use for this information are found in Legal Notices