Issues with an application opening in the same tab/window from the default portal ribbon for IE browsers

Article:TECH182554  |  Created: 2012-02-28  |  Updated: 2012-03-09  |  Article URL http://www.symantec.com/docs/TECH182554
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Article Type
Technical Solution


Subject

Issue



Issues with an application opening in the same tab/window from the default portal ribbon for IE browsers.


Cause



If a user launches an application from the default portal ribbon that works fine when opened in a new tab/window but has problems when being opened in the same tab/window for IE browsers, it could be an issue with the application on the vendor's end.

When an application is launched in the same tab/window it is placed in an IFRAME.  There are some applications that do not want to be contained within an IFRAME and are coded that way for security.

If you have confirmed with the vendor that the application should work with no problems in an IFRAME, it might be due to the application not referencing a Privacy Policy.

As it is, Internet Explorer gives lower level of trust to IFRAME pages (IE calls this "third-party" content). If the page inside the IFRAME doesn't have a Privacy Policy, its cookies are blocked (which is indicated by the eye icon in status bar, when you click on it it shows you a list of blocked URLs).


Solution



You can verify if the application is referencing a privacy policy by using tools such as Fiddler2, Charles proxy, and httpfox to view the response headers from the application. If there is no P3P header shown being passed back then you will need to work with the vendor to have that configured and working.




Article URL http://www.symantec.com/docs/TECH182554


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