Symantec Email Submission Client (SESC) does not start after computer reboot

Article:TECH182775  |  Created: 2012-03-01  |  Updated: 2014-08-18  |  Article URL http://www.symantec.com/docs/TECH182775
Article Type
Technical Solution


Issue



SESC service is not started.  Some of the following symptoms may exist as well:

Spam submission folders for new users are not created.
Email in spam submission folders is not processed.

Conditions

  • This issue occurs after a computer restart.

Look in the Windows System Event log for the entry regarding SESC not being able to start:

Log Name:      System
Source:        Service Control Manager
Date:          2/29/2012 10:36:54 AM
Event ID:      7036
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      sesc-3.2k8domain.test
Description:
The Symantec Email Submission Client service entered the stopped state.

Then look for the entry that the W3SVC service has started up:

Log Name:      System
Source:        Service Control Manager
Date:          2/29/2012 10:36:55 AM
Event ID:      7036
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      sesc-3.2k8domain.test
Description:
The World Wide Web Publishing Service service entered the running state.

If the W3SVC service starts after the SESC service then this condition is met.


Error



  • The following event appears in the Windows Application Event log:

Log Name:      Application
Source:        Symantec Email Submission Client
Date:          2/29/2012 10:36:54 AM
Event ID:      13
Task Category: Application
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      sesc-3.2k8domain.test
Description:
Failed to start the service.
Reason: The Symantec Email Submission Client website failed to start. Service will not start.

 

  • The following appears in the SESC debug log:

   
[::]2012-02-29 10:36:54,038, [6], ERROR, Symantec.Submission.Common.Utilities.WebServiceHelper, Failed to start the website.[::]
Microsoft.Web.Administration.ServerManagerException: The World Wide Web Publishing Service (W3SVC) is stopped. Web sites cannot be started unless the World Wide Web Publishing Service (W3SVC) is running.
   at Microsoft.Web.Administration.Site.Start()
   at Symantec.Submission.Common.Utilities.WebServiceHelper.Start()
[::]2012-02-29 10:36:54,787, [6], ERROR, Symantec.Submission.Service.ServiceMain, Failed to start service[::]
System.Exception: The Symantec Email Submission Client website failed to start. Service will not start
   at Symantec.Submission.Service.SubmissionService.OnStart()
   at Symantec.Submission.Service.ServiceMain.OnStart(String[] args)

 

See the following article about SESC debug logging: How to Obtain Debug logs for Symantec Email Submission Client (SESC).


Environment



  • SESC 1.X

Cause



Part of the SESC product runs as a web site installed into IIS.  The SESC service checks to see if the SESC web site is running.  If the SESC web site is not running the SESC service stops and does not restart.

During the computer restart the W3SVC service may start before or after the SESC service.  If the W3SVC service starts after the SESC service then the SESC web site check fails and the SESC service stops.


Solution



Symantec is aware of this issue.  This article is updated as more information is available.  Subscribe to this article to receive updates.

Workaround

Create a service dependency for SESC on the W3SVC service.  When the computer restarts the SESC service will start after the W3SVC service.  

1. Download the attachment sescdepends.reg to the SESC computer.
2. Double click on the sescdepends.reg file.
3. Click the Yes button on the Registry Editor confirmation dialog window.
4. Click the OK button to close the Registry Editor import confirmation window.


 


Attachments

sescdepends.reg (169 Bytes)

Supplemental Materials

SourceETrack
Value2707086



Article URL http://www.symantec.com/docs/TECH182775


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