Backup of Virtual Machines complete with following exception: "Failed to mount one or more virtual disk images" when GRT is enabled

Article:TECH182878  |  Created: 2012-03-02  |  Updated: 2014-07-08  |  Article URL http://www.symantec.com/docs/TECH182878
Article Type
Technical Solution


Issue



Backup of Virtual machines completes with exception: "Failed to mount one or more virtual disk images" and GRT view is not available in the restore selections

 


Error



Exceptions: V-79-57344-38721 - Failed to mount one or more virtual disk images

SGMON  reports the following error:

BEREMOTE: [01.03.12 13:34:37] [3900]     [fsys\shared]        - VDDK-Log: DiskLibProvider_GetDisk: Open successful - index 0.
BEREMOTE: [01.03.12 13:34:37] [4440]     [mounter]            - VMDKRemoteImage::mountDisks()  Could not open the mount the volume 0. Error Text: 'Driver not found' Error: '24307'
BEREMOTE: [01.03.12 13:34:37] [2984]     [fsys\shared]        - VDDK-Log: Vmount library: Error 2 while opening VSTOR2 driver's control device
BEREMOTE: [01.03.12 13:34:37] [2984]     [fsys\shared]        - VDDK-Log: Vmount library: Error 2 while opening VSTOR2 driver's control device
BEREMOTE: [01.03.12 13:34:37] [4440]     [mounter]            - VMDKRemoteImage::mountDisks()  Could not open the mount the volume 1. Error Text: 'Driver not found' Error: '24307'
BEREMOTE: [01.03.12 13:34:37] [4440]     [engidrapi]          - CDiskLayoutImplementation::SetAutoMount: Disabling AUTOMOUNT
BEREMOTE: [01.03.12 13:34:37] [4440]     [mounter]            - VDiskMounter::MountAllDisks:failed VirtualSystem::Initialize()
BEREMOTE: [01.03.12 13:34:37] [4440]     [mounter]            - Error mounting disks (0xe0009741)
BEREMOTE: [01.03.12 13:34:37] [4440]     [fsys\ntfs\img_pdi]  + img_pdi_attach.cpp (551):
BEREMOTE: [01.03.12 13:34:37] [4440]     [fsys\ntfs\img_pdi]  | Error mounting disk(s): E_IMG_FS_FAILED_TO_MOUNT_VIRTUAL_DISK (0xe0009741).
BEREMOTE: [01.03.12 13:34:37] [4440]     [mounter]            - CommonMounter::~CommonMounter called
BEREMOTE: [01.03.12 13:34:37] [4440]     [mounter]            - VMDKRemoteImage::unmountDisks()  Could not dismount the volume 0. Error Text: 'The specified volume is not mounted' Error: '24304'
BEREMOTE: [01.03.12 13:34:37] [4440]     [mounter]            - VMDKRemoteImage::unmountDisks()  Could not dismount the volume 1. Error Text: 'The specified volume is not mounted' Error: '24304'
BEREMOTE: [01.03.12 13:34:37] [3900]     [fsys\shared]        - VDDK-Log: VixDiskLibReaderWriter::Close: Closing disk


Environment



ESX 5.0

Backup Exec 2012

Backup exec 2010.

Backup Exec 2014.


Cause



The error in the Backup Exec job log is generic but after reviewing the sgmon log which shows error ''Driver not found' Error: '24307'' it means that VMware agent is not configured or installed correctly on the Backup Exec Server.

*See the related article on how to use SGMON for debugging.


Solution



  1. In order to install the VMware agent correctly, you need to uninstall the VMware license key from Backup exec and reinstall it. By doing this it will reinstall all the VMware components that get installed while installing the license. Here are the steps:

In Backup Exec 2010, Click on 'Tools' menu, then 'Install Options and Licenses keys on this Media Server'. In Backup Exec 2012, click on the Home button, click 'Installation and Licensing' and then click 'Install Options and Licenses on this Backup Exec Server'.

  • Remove the Agent for VMware (AVVI) license key, which will remove the Vmware Agent.
  • Then add the Vmware agent license back in Backup Exec which will reinstall the agent
  • Try to run the VM backups again.

 

  1. The beremote log can also give the following error, if so, then try the steps mentioned below:

Beremote Debug logs show the following:

[fsys\shared]       - VDDK-Warn: VixDiskLibVim: Not licensed to use this function.
[fsys\shared]       - VDDK-Log: VixDiskLibVim: TicketLogout
[mounter]             - VMDKRemoteImage::Open()  Could not open the disk '[File Servers]Test/Test01_1.vmdk' Error Text: 'Host is not licensed for this feature' Error: '16064'

This error in logs could occur, if ESX may not be licensed with the vStorage APIs feature or The account used to backup the Virtual Machines from vCenter doesn't have 'administrator' rights on vCenter.

  1. Make sure ESX is licensed with the Vstorage APIs feature.
  2. Make sure that the account used to backup the Virtual Machines has 'administrator' rights on Vcenter and is member of local  administrator on that server.

 

  1. Some time the Job may also give the same error but as exception. This exception only causes Granular Restore Technology (GRT) not to function properly. The virtual machine is still backed up and able to be recovered.  This can happen if DNS is not working. To resolve, Make sure that the Media Server, Virtual Center, and ESX servers can ping each other by hostname as well as Fully Qualified Domain Name.

 

  1. Such exception can also occur if the Virtual machine getting backed up has one or more Independent disk. The independent disks cannot be snapped by design. In such case, try the following suggestions:
  • Install the Backup Exec remote agent on the OS that the independent disk is assigned to and backup the files/folders through that agent.
  • Do not use independent disks in the VM’s.
  • Perform non-GRT backup jobs of the systems with independent disks. This will only backup the non-independent disks in the virtual machine. The data on the independent VMDK will need to be backed up as per first point.




Article URL http://www.symantec.com/docs/TECH182878


Terms of use for this information are found in Legal Notices