"Unable to read configuration: server not allowed access (46)" after selecting Change Server using the Windows Remote Administration Console

Article:TECH184048  |  Created: 2012-03-16  |  Updated: 2012-06-15  |  Article URL http://www.symantec.com/docs/TECH184048
Article Type
Technical Solution


Environment

Problem



The NetBackup Windows Remote Administration Console (RAC) should be capable of administering multiple NetBackup master servers.   

Once the RAC is launched and connected to a master, in order to administer a different master (assuming all of the permissions are in place), simply perform a Change Server operation.

In NetBackup 7.5, it is possible to experience the error: Unable to read configuration: server not allowed access (46) when attempting to administer multiple NetBackup masters.  Connecting to an alternate master is successful, but certain operations - for example, clicking into Activity Monitor or opening Host Properties - will fail with the noted error.
 


Error



Unable to read configuration: server not allowed access (46)


Environment



This issue only affects the Windows Remote Administration Console.  The Java consoles are not affected.


Cause



In NetBackup 7.5, in order for the Windows Remote Administration Console to administer a remote master, that server's hostname name must reside on the Server list on the host running the Console.

On Windows, the Server list is located in this registry location:
HKEY_LOCAL_MACHINE\SOFTWARE\Veritas\NetBackup\CurrentVersion\Config

'Server' = REG_MULTI_SZ

All masters which the RAC needs to connect to must appear in this list.

The problem is that only the first server on the list can be successfully administered.  The other servers generate the previously noted error.


Solution



The formal resolution to this issue (Etrack 2704905) is included in the following release:

  • NetBackup 7.5 Maintenance Release 3 (7.5.0.3)

Information on NetBackup 7.5.0.3 availability is now available at the link provided in the Related Article linked below.

Workaround:
If the error is encountered, modify the contents of the Server registry key, placing the problematic master server at the top of the list.   This will allow the Windows Remote Access Console to successfully administer the desired master server.

Note: Once the change is made, you may have to restart the Windows Remote Administration Console.


Supplemental Materials

SourceError Code
Value46
Description

server not allowed access


SourceETrack
Value2704905
Description

Windows Remote Admin Console gives "(46) server not allowed access" if not connecting to first server on the list.




Article URL http://www.symantec.com/docs/TECH184048


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