HotFix for Symantec Enterprise Vault (EV) for Microsoft Exchange 9.0.4, Build 1097, Event ID: 2776 about "An exception occurred in routine CArchivingAgentQueue::CanUserRegisterMailBox()" during EV MAC clients registration

Article:TECH185630  |  Created: 2012-04-02  |  Updated: 2014-02-28  |  Article URL http://www.symantec.com/docs/TECH185630
Article Type
Technical Solution


Issue



Event ID: 2776 "An exception occurred in routine CArchivingAgentQueue::CanUserRegisterMailBox()".

This error indicates that an EV MAC Client registration has failed, and this is logged every time a registration attempt fails.

 


Error



Error message displayed in the Enterprise Vault event viewer

The agentclientbroker.exe dtrace contains

(AgentClientBroker) <9100> EV:M CMailboxHelper::OpenMailboxAndFolder() - Open the folder, @PR_IPM_SUBTREE_ENTRYID\Inbox
(AgentClientBroker) <9100> EV:M CArchiveAgentTask::GetMapiObject - Com Exception [0x800B0001]
(AgentClientBroker) <9100> EV:M ICARA- Exiting GetMapiObject routine, Status: [0x800B0001]
(AgentClientBroker) <9100> EV:M ICARA- Error in GetMapiObjectsForClientRequest
(AgentClientBroker) <9100> EV~E Event ID: 2776 An exception occurred in routine CArchivingAgentQueue::CanUserRegisterMailBox() |
(AgentClientBroker) <9100> EV:M ICARA-Exiting routine CArchivingAgentQueue::CanUserRegisterMailBox, Status: [0xC0040AD8]
 

The EV MAC Client log 'EnterpriseVault.log' contains the following: 

<?xml version="1.0" standalone="yes"?>
<EnterpriseVaultClient Version="1.0">
    <Mailbox ClientOSType="2" MbxServerType="0">
        <Result Status="2" Reason="Access Denied"></Result>
    </Mailbox>
</EnterpriseVaultClient>


Environment



EV Mac client installed on supported MAC OSX using Entourage 2008 or Outlook 2011

 


Cause



From Exchange 2003 onwards if a mailbox is first opened by a non-english Outlook the folders beyond 'Top if Information Store' are created respecting the Outlook language.

For example the Inbox would be: 

English Top of Information Store\Inbox
German Top of Information Store\Posteingang
Italian Top of Information Store\Posta in arrivo
French Top of Information Store\Boite de rèception

The failed registration occurs because the call to register the EV Mac clients always looks for "Top of Information Store\Inbox" (@PR_IPM_SUBTREE_ENTRYID\Inbox).
 


Solution



What issue(s) does this hotfix resolve?

Etrack: 2699600 - "EV MAC Client cannot register into table 'RegisteredClientMailboxes' - Event ID 2776 - An exception occurred in routine CArchivingAgentQueue::CanUserRegisterMailBox()"

Which files does this hotfix replace?

File Name File Version New File Version
AgentClientBroker.exe 9.0.4.1097 9.0.4.1103
AgentClientBrokerps.dll 9.0.4.1097 9.0.4.1109

How to install this hotfix:

1. Stop all Enterprise Vault services

2. Open the Enterprise Vault installation folder (typically on C:\Program Files\Enterprise Vault or C:\Program Files (x86)\Enterprise Vault) and rename the existing AgentClientBroker.exe and AgentClientBrokerps.dll to AgentClientBroker.original and AgentClientBrokerps.original

3. Extract the hotfix content and copy the new files AgentClientBroker.exe and AgentClientBrokerps.dll into the Enterprise Vault installation folder (typically on C:\Program Files\Enterprise Vault or C:\Program Files (x86)\Enterprise Vault)

4. Start all the Enterprise Vault services


Attachments

EV 9.0.4 Hotfix Etrack 2699600
EV_9.0.4_Hotfix Etrack_2699600.zip (300 kBytes)

Supplemental Materials

SourceETrack
Value2699600
Description

EV MAC Client cannot register into table 'RegisteredClientMailboxes' - Event ID 2776 - An exception occurred in routine CArchivingAgentQueue::CanUserRegisterMailBox()




Article URL http://www.symantec.com/docs/TECH185630


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