Status result for Monitor Plug-in task does not display in Task UI

Article:TECH185815  |  Created: 2012-04-04  |  Updated: 2012-04-04  |  Article URL http://www.symantec.com/docs/TECH185815
Article Type
Technical Solution


Issue



When a Rule has been configured with associated Monitor Agent Client side task and the Rule triggers, the status of the Task Run is never displayed int he UI.


Environment



Monitor Solution 7.0 and 7.1 releases, all service packs.

Rules configured with Monitor Agent "client" side tasks.

 


Cause



Task execution result is not displayed in the Tasks UI console because this task was initiated from "client" side. Task Server is not invoked and thus the taks status is not displayed.
Task successfully run but yet the Task Results are empty. For Rules with Task Server based Tasks, Task results are displayed.


Solution



Below is a SQL Query which will display the client side tasks by completion time from most recent completed client –side task to oldest. This query can be used in a report to produce Client side task statuses:

select
                vt.name,
                taskItem.Name,
                task_log._eventTime
from Evt_Policy_Compliance_Remediation task_log
join  Evt_Task_Instances AS eti on eti.TaskInstanceGuid = task_log.TaskInstanceGuid
join ItemVersions taskVersion on taskVersion.VersionGuid=eti.TaskVersionGuid
join ItemReference AS ir1 ON taskVersion.ItemGuid = ir1.ChildItemGuid AND ir1.Hint = 'ruleclienttask'
join Item AS taskItem ON ir1.ChildItemGuid = taskItem.Guid
join vItem as vt on task_log._resourceguid = vt.guid
order by task_log._eventtime desc

 

 




Article URL http://www.symantec.com/docs/TECH185815


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