The Backup Exec Preinstall Environment Checker for 2012 will upgrading from 2010 it displays an error "Unexpected Error Occurred"

Article:TECH186084  |  Created: 2012-04-09  |  Updated: 2012-04-09  |  Article URL http://www.symantec.com/docs/TECH186084
Article Type
Technical Solution

Product(s)

Issue



On the Backup Exec Preinstall Environment Checker for 2012 will upgrading from 2010 it displays an error "Unexpected Error Occurred"


Error



In the  Symantec Backup Exec (TM) 2012 Installation Log:

03-28-2012,14:23:30 : Backup Exec version 13.0.5204 is registered with the system.
03-28-2012,14:23:30 : Writing Install Registry Value (Software\Symantec\Backup Exec For Windows\Backup Exec\14.0\Install\Upgrade Version: 13.0.5204.0)
+ 03-28-2012,14:23:30 : Failed to Read Install Registry Value (Software\Symantec\Backup Exec For Windows\Backup Exec\14.0\Install\Path: )
+ 03-28-2012,14:25:07 : The install failed with an unexpected error:Not found
+ 03-28-2012,14:25:07 : at System.Management.ManagementScope.Initialize() at System.Management.ManagementObject.Initialize(Boolean getObject) at System.Management.ManagementClass.GetInstances(EnumerationOptions options) at Symantec.IFrameSDK.CommonOps.CSysInfoOps.GetComputerModel(String& strComputerModel) at Symantec.BackupExec.BeSeqDlgs.BEDlgSequence.InitAsDellProvisioningOption(SharedData pSharedData) at Symantec.BackupExec.BeSeqDlgs.BEDlgSequence.InitializeUpgradeInstall(SharedData pSharedData) at Symantec.BackupExec.BeSeqDlgs.BEDlgSequence.InitSharedData(SharedData pSharedData) at Symantec.IFrameSDK._Setup.ProductSequence.InitSharedData(SharedData data) at a.a(String[] A_0)
+ 03-28-2012,14:25:07 : If this install is being run from a network share, copying the media locally and retrying the install may resolve this issue.
+ 03-28-2012,14:25:12 : ERROR: Installation failed with error -532459699. GetLastError = :0
 


Cause



Possible cause for this issue is either a bad download of the installer to the machine or an issue with wmi that is installed on the machine. 

 


Solution



  • Confirm that the downloaded ISO is complete and can be started on another machine that is available as a test for the install. (This part is only a test to confirm that the iso works)
  • Confirm that WMI is installed on the machine that is backup exec is being installed on.
  • Confirm that WMI is running correctly on the machine.

1.To diagnose issues with the WMI, use the WMI diagnosis utility:


          http://www.microsoft.com/downloads/details.aspx?familyid=D7BA3CD6-18D1-4D05-B11E-4C64192AE97D&displaylang=en


2.To troubleshoot WMI issues, go to the following site:

         http://www.microsoft.com/technet/scriptcenter/topics/help/wmi.mspx

3.The commands in the list below can be run in a Windows command prompt to re-register WMI.

 
net stop winmgmt
 
cd /d %windir%\system32\wbem
 
for %i in (*.dll) do RegSvr32 -s %i  
 
scrcons.exe /RegServer  
 
unsecapp.exe /RegServer
 
wbemtest.exe /RegServer
 
winmgmt.exe /RegServer
 
wmiadap.exe /RegServer
 
wmiapsrv.exe /RegServer
 
wmic.exe /RegServer
 
wmiprvse.exe /RegServer
 
net start winmgmt
 

4.Alternatively, they can be run via CMD or BAT files; however, the third line will need to modified as follows:

 
for %%i in (*.dll) do RegSvr32 -s %%i
 

5.In either case, this should resolve the WMI errors and the Backup Exec installation should complete successfully. 



Article URL http://www.symantec.com/docs/TECH186084


Terms of use for this information are found in Legal Notices