Unable to launch the console. Error occurred while checking application server version for client compatibility.

Article:TECH186455  |  Created: 2012-04-13  |  Updated: 2012-04-13  |  Article URL http://www.symantec.com/docs/TECH186455
Article Type
Technical Solution


Issue



You are connecting to the Control Compliance Suite Application sever targeting the FQDN. You can ping the CCS application server by FQDN too. Services are up and running - possibly other CCS consoles can connect to the application server but you get an error:

 

 

 


Error



2012-02-09 12:41:20.341,2012-02-09 12:41:20.341,VM-WINXP,Error,PreLaunchActivityProvider,SymConsole,2600,,1,DoConnect,,0,1,"PreLaunchActivity.CheckApplicationServerVersion : System.ServiceModel.EndpointNotFoundException: Could not connect to net.tcp://{application server short name}:1431/CCS/Services/InfraBridge/ConfigInfo/WindowsSecurity. The connection attempt lasted for a time span of 00:00:20.9684816. TCP error code 10065: A socket operation was attempted to an unreachable host 127.0.0.2:1431. ---> System.Net.Sockets.SocketException: A socket operation was attempted to an unreachable host 127.0.0.2:1431 at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

 


Environment



Control Compliance Suite 10.5.1 PCU 2012-1 and earlier.

 


Cause



Although addressing the CCS application server by FQDN - internally the system is addressing the CCS application server by short name (netbios) - this is considered a programming error.

 


Solution



Short term solution is either;

  • edit your host file (on the console system) and add an entry for the short name of the CCS application server or,
  • Edit your network settings and add a search domain for the domain the application server resides in.

Long term solution will be provided in a future CCS 11.5.1 PCU.

 




Article URL http://www.symantec.com/docs/TECH186455


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