Error message while uninstalling Symantec Mail Security for Microsoft Exchange: "Error 1722. There is a problem with this Windows Installer package."

Article:TECH187082  |  Created: 2012-04-23  |  Updated: 2014-07-09  |  Article URL http://www.symantec.com/docs/TECH187082
Article Type
Technical Solution


Issue



While removing Symantec Mail Security for Microsoft Exchange (SMSMSE) the following error message is displayed:

Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.

The installer rolls back and SMSMSE is not uninstalled.

Conditions

  • Uninstall MSI log shows the following sequence:

1. Turn on verbose MSI logging using the steps from the following article: How to obtain detailed MSI logging while installing or uninstalling Symantec Mail Security for Microsoft Exchange (SMSMSE).
2. Attempt to run the SMSMSE uninstallation.
3. Open the MSI log file generated in the %TEMP% directory in an editor.
4. The log shows the following errors:

Action start 14:34:23: UnregisterSAVFMSELU_Dll_UI_Only.
MSI (s) (68:48) [14:34:24:208]: Note: 1: 1722 2: UnregisterSAVFMSELU_Dll_UI_Only 3: C:\Windows\system32\ 4: C:\Windows\system32\regsvr32.exe /u /s "C:\Program Files\Symantec\CMaF\2.1\bin\Products\SMSMSE\6.5\SAVFMSELU.dll"
CustomAction UnregisterSAVFMSELU_Dll_UI_Only returned actual error code 5 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (68:48) [14:45:37:903]: Product: Symantec Mail Security for Microsoft Exchange -- Error 1722.There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  Action UnregisterSAVFMSELU_Dll_UI_Only, location: C:\Windows\system32\, command: C:\Windows\system32\regsvr32.exe /u /s "C:\Program Files\Symantec\CMaF\2.1\bin\Products\SMSMSE\6.5\SAVFMSELU.dll"

This shows that the uninstall process is unable to un-register SMSMSE from LiveUpdate. 

  • A prior version of SMSMSE was installed at the same time as the current version.  Then the prior version was uninstalled while this version was still installed.

 


Cause



SMSMSE allows multiple versions of the console to be installed at the same time.  This allows an administrator to manage different software versions at the same time.

When the SMSMSE console is uninstalled it unregisters SMSMSE from LiveUpdate.  This happens even if there is a different version of SMSMSE still installed. When the subsequent version of SMSMSE is uninstalled it also attempts to unregister from LiveUpdate.  This fails because SMSMSE is not currently registered with LiveUpdate.  The installer reports this error and stops.


Solution



Workaround

Manually register SMSMSE with LiveUpdate and then uninstall.

1. Run the following command from a "run as administrator" command prompt:

C:\Windows\system32\regsvr32.exe  "C:\Program Files\Symantec\CMaF\2.1\bin\Products\SMSMSE\6.5\SAVFMSELU.dll"

NOTE:  The path above locates the DLL for 6.5 version when installed in the default location in a Windows 2003 server.

C:\Windows\system32\regsvr32.exe  "C:\Program Files (x86)\Symantec\CMaF\2.1\bin\Products\SMSMSE\6.5\SAVFMSELU.dll"

NOTE:  The path above locates the DLL for 6.5* version when installed in the default location in a Windows 2008 server.

2. Run the uninstallation.

 *for version 7.0.1 it is 7.0


Supplemental Materials

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Article URL http://www.symantec.com/docs/TECH187082


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