File is not a valid pcAnywhere file error appears, showing pcANSHost.BHF as the problematic file.

Article:TECH187737  |  Created: 2012-04-30  |  Updated: 2014-06-12  |  Article URL http://www.symantec.com/docs/TECH187737
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Article Type
Technical Solution

Product(s)

Subject

Issue



NOTE:  The resolution to this issue has been superseded.  The fix has been included in the pcAnywhere Solution 12.6.7 Hotfix 1 update, and is also now included in pcAnywhere solution 12.6.8 as provided in Symantec Client Management Suite 7.5 SP1 release.   http://www.symantec.com/docs/DOC7355   Either of these updates are available through the Symantec Installation Manager.  For more information on applying this update, please see How to apply latest pcAnywhere updates to pcAnywhere solution 12.6.7. If you are unable to apply the hotfix, please use the information provided below.

 

After upgrading to pcAnywhere Solution 12.6.7, and upgrading the pcAnywhere agent plug-in on managed computers to the corresponding version 12.6.8096, an error appears on managed computers.


Error



File is not a valid pcAnywhere file.  C:\Documents and Settings\All Users\Application Data\Symantec\pcAnywhere\Hosts\pcANSHost.BHF

File is not a valid pcAnywhere file.  C:\ProgramData\Symantec\pcAnywhere\pcANSHost.BHF


Environment



pcAnywhere Solution 12.6.7

Symantec pcAnywhere Agent 12.6.8096
 


Cause



This issue is the result of a defect which is introduced when the "pcAnywhere Plug-in for Windows - Upgrade" policy runs on managed computers which already have the latest pcAnywhere Agent.
 

Solution



Please refer to HOWTO82334 for the official fix for this issue.  It will be updated as new versions of the pcAclientInstallManager are released.

Following are instructions to apply the fix to each Notification Server (NS) in your environment which has pcAnywhere Solution 12.6.7:

  1. Turn off both the pcAnywhere Plug-in for Windows – Install and pcAnywhere Plug-in for Windows – Upgrade policies

  2. Store a backup copy of the original file from the pcAAgent package folder on the NS, \Program Files\Altiris\Notification Server\NSCap\bin\Win32\X86\pcAAgent\pcAClientInstallManager.exe.   Save the backup in a different location on the NS, not in the pcAAgent folder.

  3. Download the zip file from HOWTO82334 it contains the most current version of the patch.  Extract the pcAClientInstallManager.exe to a temporary folder.

  4. Overwrite the original file, \Program Files\Altiris\Notification Server\NSCap\bin\Win32\X86\pcAAgent\pcAClientInstallManager.exe, with the new file.

  5. Update the distribution points for the pcA install package: 
         Within the Symantec Management Console, navigate to Manage > All Resources > Package > Software Package
         Search for "pcAnywhere"
         Right-click the item "pcAnywhere Plug-in Package" and select "Update Distribution Points"

  6. Clone the pcAnywhere Plug-in for Windows – Upgrade policy

  7. Be sure to test this point fix before applying it in a production environment:
         At first, target the clone of the pcAnywhere Plug-in for Windows – Upgrade policy to a very limited number of computers which show the error.
         Verify that the new pcAClientInstallManager.exe file is downloaded to C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{B364DA8F-1735-4DD3-865A-8B33CA5523CD}\cache on each test computer before the Upgrade policy runs.
         Verify that the error message has been resolved.

  8. After performing a satisfactory test, modify the target the cloned policy to suit your needs.
         If all computers with the pcAnywhere Agent are affected by the error shown above, then use the target filter "pcAnywhere Plug-in for Windows Installed Active"
         If some computers are affected by the error and you can target them with another filter or computer list, do so.

  9. Uncheck the “Run Once ASAP” option.

  10. Schedule the policy to run at a certain time.  Do not set a repeating schedule for this clone of the Upgrade policy.

  11. Turn the Upgrade policy On, and click Save Changes

  12. Run the Update Client Configuration task, targeted to the filter "pcAnywhere Plug-in for Windows Installed Active".  This will force the agents to recognize that the new Update policy is assigned and to download the new package.

  13. Turn On the "pcAnywhere Plug-in for Windows – Install" policy now, or at a future point in time as needed.


    Once the issue addressed in this article has been fixed on all affected computers:

  14. Turn Off the clone of the "pcAnywhere Plug-in for Windows - Upgrade" policy which was used to deliver this fix.  

  15. Turn On the original pcAnywhere Plug-in for Windows - Upgrade (or another clone of it) which targets the default filter, "Windows computers requiring pcAnywhere plug-in Upgrade".

 


Supplemental Materials

SourceETrack
Value2761696

SourceETrack
Value2864662



Article URL http://www.symantec.com/docs/TECH187737


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