The LiveUpdate session exited with a return code of 1835: Error - The LiveUpdate server failed to respond in a reasonable amount of time.

Article:TECH188847  |  Created: 2012-05-15  |  Updated: 2013-01-11  |  Article URL http://www.symantec.com/docs/TECH188847
Article Type
Technical Solution

Product(s)

Issue



Attempts to update Symantec Endpoint Protection fail, with LiveUpdate sessions ending with error code 1835.


Error



Per Log.LiveUpdate:

2012-5-15, 2:40:07 GMT -> HR 0x802A0046 DECODE: E_UNABLE_TO_READ_DATA_FROM_SERVER
2012-5-15, 2:40:07 GMT -> EVENT - SESSION END FAILED EVENT - The LiveUpdate session ran in Silent Mode. LiveUpdate found 27 updates available, of which 0 were installed and 27 failed to install.  The LiveUpdate session exited with a return code of 1835, The LiveUpdate server failed to respond in a reasonable amount of time.


Environment



Windows server 2003

Symantec Endpoint Protection 11.0 RU5


Cause



LiveUpdate session timeouts via HTTP with the default timeout setting.


Solution



To overcome this issue, change the timeout setting for LiveUpdate to extend the session period.

1. As per OS, browse to

Windows 2003: Default location is C:\Documents and Settings\All Users\Application Data\Symantec\Liveupdate
Windows 2008: Default location is C:\Programdata\Symantec\Liveupdate.

2. Open Settings.Liveupdate, find

PREFERENCES\INTERNET_CONNECT_TIMEOUT=45
PREFERENCES\INTERNET_READ_DATA_TIMEOUT=45

Change the default setting of 45 to a larger number, for example 300.

3. Save Settings.Liveupdate.

4. Run LiveUpdate to verify success.





Article URL http://www.symantec.com/docs/TECH188847


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