Catalog Backup DR file and notification is not sent as email when the Master server is configured on NetBackup 52x0 appliances.

Article:TECH188948  |  Created: 2012-05-16  |  Updated: 2012-05-22  |  Article URL http://www.symantec.com/docs/TECH188948
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution

Product(s)

Issue



If configured correctly both at NetBackup and the appliance levels, when the Catalog backup completes, it should send an email with the DR file attached.

The purpose of this technote is to describe what needs to configure and which logs need to be investigated.


Error



bpdbm log shows that the mail_dr_info.sh script is executed, so bpdbm has done it's job:

16:01:49.632 [8703] <2> exec_catalog_DR_protection: Writing DR image to /tmp/catalog_backup/catalog_host-1_1337198505_FULL

16:01:49.632 [8703] <2> exec_catalog_DR_protection: Sending DR image info via email
16:01:49.632 [8703] <4> db_DR_generate_report: ?
16:01:49.637 [8703] <4> db_DR_send_report: ?
16:01:49.637 [8703] <2> db_DR_send_report: Start OVsystem("/usr/openv/netbackup/bin/mail_dr_info.sh" "abd_def_symantec.com" "NetBackup Catalog Backup successful on host host-1 status 0" "/usr/openv/netbackup/db/mail/host-1_1337198505" "/tmp/catalog_backup/catalog_133 7198505_FULL")
16:01:52.272 [8703] <2> db_DR_send_report: End OVsystem(/usr/openv/netbackup/bin/mail_dr_info.sh)

But if you check the '/var/log/mail' file on the appliance, you will not find any event suggesting the mail is processed and sent by postfix.

Below are the sequence of events seen in '/var/log/mail' file when an email is sent, note 'status=sent (delivered to mailbox)'

May 3 21:00:29 nbu5200 postfix/pickup[15366]: 114F031001FF: uid=0 from=<root> May 3 21:00:29 nbu5200 postfix/cleanup[19788]: 114F031001FF: message- id=<20120503210029.114F031001FF@nbu5200.veritas.com>

May 3 21:00:29 nbu5200 postfix/qmgr[7655]: 114F031001FF: from=<root@nbu5200.veritas.com>, size=892, nrcpt=1 (queue active)
May 3 21:00:29 nbu5200 postfix/local[19790]: 114F031001FF: to=<root@nbu5200.veritas.com>, orig_to=<root>, relay=local, delay =0.34, delays=0.34/0/0/0, dsn=2.0.0, status=sent (delivered to mailbox)

Environment



NetBackup 52x0 Appliances running as NetBackup Master Server.


Cause



Incomplete configuration and/or incomplete script may be the reason for this issue.


Solution



Make sure the following items are configured correctly both at NetBackup and Appliance layer:

1. Make sure the followings are done in NetBackup policy created for the NetBackup Catalog backup using the NetBackup Administration console.

    a. 'Path' is set under Disaster Recovery tab for the Catalog backup policy

    b. email address is defined in the "E-mail address" section under Disaster Recovery tab for the Catalog backup policy.

    c. 'Send in an E-mail attachment' checkbox is checked.

 2.  Do the followings on the appliance:

    a. Add the same email address on the appliance

        Use Settings >Email Software Add under CLISH interface

        Please note that the above step is not required for appliances running version 2.5

    b. set SMTP server on the appliance

        Use Settings > Email SMTP Add under CLISH interface

    3. Also please make sure  'use MIME::Base64;' exists in the script '/opt/NBUAppliance/scripts/nbapp_common.pm'

    Please note that the above step is not required for appliances running version 2.0.2 and above

    If the appliance is running version 2.0.1 or lower, please consult TECH174575





Article URL http://www.symantec.com/docs/TECH188948


Terms of use for this information are found in Legal Notices