Error Page Appears when Adding Some Users as Primary Contacts
| Article:TECH189118 | | | Created: 2012-05-18 | | | Updated: 2012-05-22 | | | Article URL http://www.symantec.com/docs/TECH189118 |
Problem
Error Page Appears when Adding Some Users as Primary Contacts
Error
'The Primary Contact does not exist in the portal" and 'Could not find [UserInfo] where [EmailAddress] Equal [email@domain.com]
Environment
Servicedesk 7.1.1
Cause
Missing a correlated Email Address in the UserEmailAddress table for the Primary Contact
Solution
The following script generates the missing email addresses in the UserEmailAddress table
-- run to fix broken users - "can't find userinfo for blahblah"
declare @userid nvarchar(36),
@primaryemail nvarchar(255)
declare u_cursor CURSOR FOR select u.UserID, u.PrimaryEmail
from [User] u
where not exists (Select *
from UserEmailAddress uea
where u.UserID = uea.UserID and
u.PrimaryEmail = uea.EmailAddress)
open u_cursor
fetch next from u_cursor INTO @userid, @primaryemail
while @@fetch_status = 0
begin
insert into UserEmailAddress (UserEmailAddressID, EmailAddress, UserID, SendNotificationsHere) values
(NEWID(), @primaryemail, @userid, 1)
fetch next from u_cursor INTO @userid, @primaryemail
end
close u_cursor
deallocate u_cursor
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Article URL http://www.symantec.com/docs/TECH189118
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