NetBackup 52x0 appliance version upgrade fails if one of the component fails during the Self Test

Article:TECH189370  |  Created: 2012-05-22  |  Updated: 2012-05-22  |  Article URL http://www.symantec.com/docs/TECH189370
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution

Product(s)

Issue



If any of the required component fails during the 'Self Test' procedure, the upgrade of NetBackup 52x0 appliance to a later version will fail.


Error



Result of self-test to confirm appliance configuration ...           failed

- [Error] Appliance self-test failed. Cannot install SYMC_NBAPP_update-2.0.3.0- 1.x86_64.rpm. Please resolve self-test failures before attempting again.

Environment



NetBackup 52x0 appliances.


Cause



'Self Test' procedure fails on one or more components.


Solution



1. Identify which component of 'Self Test' is failing. In the example below, it is failing when it is checking NetBackup configuration and whether required NetBackup services are running.

Please note that 'IPSec' component test also failed here but this is normal if IPsec is not configured.

Software> Install SYMC_NBAPP_update-2.0.3.0-1.x86_64.rpm

 - [Info] Checking prerequisites before installing SYMC_NBAPP_update-2.0.3.0-1.x8                6_64.rpm
Checking the update 'SYMC_NBAPP_update-2.0.3.0-1.x86_64.rpm' ...      ok
Checking version of local appliance ...                               2.0.1.0
Comparing appliance version with update version '2.0.3.0' ...         ok
Extracting the contents of the update ...                             ok
Running self-test to confirm appliance configuration ...
Running Sanity tests on Media Server Appliance.
 
    Checking if installation is successful ...                       [OK]
    Checking if SSH is enabled ...                                   [OK]
    Checking if hostname is set ...                                  [OK]
    Checking if IP address is set ...                                [OK]
    Checking if appliance user accounts exists ...                   [OK]
    Checking if required packages are installed ...                  [OK]
    Checking if NetBackup is configured and running ...              [FAIL]
    Checking if storage units and diskpools have been created ...    [OK]
    Checking if SLPs have been created ...                           [NA]
    Checking if required NetBackup policies have been created ...    [NA]
    Checking if OpsCenter is configured and running ...              [OK]
    Checking test backup and restore operations ...                  [OK]
    Expiring test backup images and deleting test policy ...         [OK]
    Checking IPsec setup on the box ...                              [FAIL]
 
Completed running tests on the appliance.
    SELF TEST RESULT :                                               [FAIL]

2. Run 'Support> Test software' tool itself from CLISH to verify whether it fails on the same component. If so, verify and fix the issue before trying to upgrade the appliance version again.

In the case depicted here, the appliance was a Media Server appliance and not all required services/daemons were not running.

3. in this case, NetBackup daemons were shoudown and restarted, then the appliance version upgrade was tried again and it worked fine.




Article URL http://www.symantec.com/docs/TECH189370


Terms of use for this information are found in Legal Notices