After completing a backup of a Virtual Machine with the VMware agent File Level GRT may not be available for all drives if Application GRT did not complete successfully
| Article:TECH189440 | | | Created: 2012-05-23 | | | Updated: 2012-08-24 | | | Article URL http://www.symantec.com/docs/TECH189440 |
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Problem
When backing up a virtual machine with the VMware agent that has File Level and Application Level GRT enabled, if the Application Level GRT process does not completely successfully File Level GRT may not be available for all drive.
Example:
Backup of a VM with Microsoft SQL Server installed on the E drive
Backup of the VM completes successfully but with Exceptions on the instance of Microsoft SQL Server
File Level GRT will not be available for the E drive.
Error
Error from the Backup Exec Remote Agent Debug on the SQL Server:
[fsys\sql2] - Getting file list for database
[fsys\sql2] - Returning Database DATABASENAME - Log backup supported
[fsys\sql2] - AddToSnapshotSet called
[fsys\sql2] - Building device list for snapshot
[fsys\sql2] - In GetDeviceList for DATABASENAME
[fsys\sql2] - file list query started
[fsys\sql2] - no more rows to process
[fsys\sql2] - adding device to list C:
[fsys\sql2] - Getting file list for database
[fsys\sql2] - NO data files returned for database. Probably offline. Skip backup.
Error from the Media Server Debug log:
[mounter] - CommonMounter::MountSomeApp: UpdateSqlPdi processing error -536837054 0xe0008442
| UNEXPECTED ERROR(0xe000975f): Failed to mount Virt-App
Cause
This issue is caused by having a database offline or in a restoring state when the backup occurs.
Solution
Workaround: If a database is in an offline state, either bring the database online or detach it from SQL before running the backup again.
If bringing the database online or removing it is not possible, turn off Application GRT and perform Agent backups of the database instance to allow for restore of individual databases.
Symantec Corporation has acknowledged that the above-mentioned issue is present in the current version(s) of the product(s) mentioned in this article. Symantec Corporation is committed to product quality and satisfied customers.
There are no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time. However, the issue is currently scheduled to be addressed in the next major revision of the product. Please be sure to refer back to this document periodically as any changes to the status of the defect will be reflected here. Please note that Symantec Corporation reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests. Symantec's plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.
Please contact your Symantec Sales representative or the Symantec Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue. For information on how to contact Symantec Sales, please see http://www.symantec.com
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| Value | 2794396 |
| Description | AVVI: File Level GRT Catalog is not build for the drive SQL is installed on when Application GRT is enabled and Application GRT fails. |
| Source | UMI |
| Value | V-79-57344-38749 |
| Description | Backup Exec was unable to prepare Microsoft SQL resources for Granular Recovery Technology (GRT) operations. Therefore you will be unable to perform GRT-enabled restores of Microsoft SQL data for 'SERVERNAME\INSTANCENAME' from this backup. |
Article URL http://www.symantec.com/docs/TECH189440
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