"pcAnywhere host has encountered a problem and needs to close"

Article:TECH190503  |  Created: 2012-06-06  |  Updated: 2012-08-14  |  Article URL http://www.symantec.com/docs/TECH190503
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Article Type
Technical Solution


Subject

Issue



When connecting to a pcAnywhere host from either QuickConnect or the SMP Console, the host machine errors and stops the awhost32.exe.
This only happens after updating pcAnywhere solution agent to version 12.6.7
Faulting application awhost32.exe, version 12.5.4.8096
Faulting module awofrwrk.dll, version 12.5.4.8096


Error



"pcAnywhere host has encountered a problem and needs to close"


Cause



The cause is unknown at this time but the following steps can be used as a workaround.


Solution



  1. Open an administrative command prompt (Windows Vista, 7, 2008 and 2008 r2)
  2. Type command “regsvr32 -u “Path of pcAnywhere installed directory with adsauth.dll
    • regsvr32 -u "C:\Program Files (x86)\Symantec\pcAnywhere\adsauth.dll"
    • regsvr32 -u "C:\Program Files\Symantec\pcAnywhere\adsauth.dll"
  3. Confirm you recieve the following message  DllUnregisterServer adsauth.dll succeeded.
  4. Type command “regsvr32 “Path of pcAnywhere installed directory with adsauth.dll
    • regsvr32 "C:\Program Files (x86)\Symantec\pcAnywhere\adsauth.dll"
    • regsvr32 "C:\Program Files\Symantec\pcAnywhere\adsauth.dll"
  5. Confirm you recieve the following message DllRegisterServer adsauth.dll succeeded.

If a script is going to be used a -s can be added after the regsvr32 to make the command ran silently.

Attached is a VB script that can be used to do the same task.

 

Symantec Corporation has acknowledged that the above-mentioned issue is present in the current version(s) of the product(s) mentioned at the end of this article. Symantec is committed to product quality and satisfied customers.

This issue is currently being considered by Symantec to be addressed in the next major revision of the product.  There are no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time.  Please note that Symantec reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests or introduces new risks to overall code stability.  Symantec’s plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.

Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.

Please contact your Symantec Sales representative or the Symantec Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.  For information on how to contact Symantec Sales, please refer to the following Web site:

http://www.symantec.com/business/index.jsp


Attachments

A vbscript to reregister the adsauth.dll file.
RegAdsauth.vbs (1 kBytes)


Article URL http://www.symantec.com/docs/TECH190503


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