How to disable circular logging in Microsoft Exchange 2003/2007/2010 to avoid a differential or incremental backup failure with error "snapshot preparation failed, status 130".

Article:TECH192178  |  Created: 2012-07-02  |  Updated: 2013-10-26  |  Article URL http://www.symantec.com/docs/TECH192178
Article Type
Technical Solution



Issue



Problem occurs when Microsoft Exchange full backup completes successfully but differential or incremental backups fail with error "snapshot preparation failed, status 130".


Error



07/01/2012 20:03:30 - Critical bpbrm (pid=19568) from client : FTL - snapshot preparation failed - Error attempting to find volumes to snap., status 130
07/01/2012 20:03:30 - Critical bpbrm (pid=19568) from client : FTL - snapshot preparation failed - Error attempting to find volumes to snap., status 130
07/01/2012 20:03:30 - Critical bpbrm (pid=19568) from client : FTL - snapshot preparation failed, status 130
system error occurred  (130)


Environment



Microsoft Exchange 2003. 
Microsoft Exchange 2007. 
Microsoft Exchange 2010.


Cause



Circular Logging feature enabled on Exchange Database.When circular logging is enabled, transaction log files that have already been committed to the database are overwritten, preventing the accumulation of logs. The log files are overwritten whether or not a full or incremental backup has been run, and a history of previous logs since the last full or incremental backup is not maintained. This is why, when circular logging is enabled, differential and incremental backups of the Exchange databases cannot be performed (since these types of backups rely on complete history of logs).

Note: Exchange Server supports multiple databases and storage groups on the same server. Each storage group is controlled by a separate instance of the Extensible Storage Engine (ESE). Therefore, each storage group shares the same set of log files. As a result, circular logging is enabled or disabled for a particular storage group, not for a particular database.


Solution



 

To disable circular logging in different version of Exchange Server, perform the following: 

How to Disable circular logging in Exchange Server 2003 :
  

1.       Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
2.       Expand Server, right-click the storage group that you want to change, and then click Properties.
3.       In the Properties dialog box, click to clear the Enable Circular Logging check box.
4.       Click OK. When you are prompted to confirm that you want to continue, click Yes.
5.       Restart the Microsoft Exchange Information Store service. To do this, follow these steps:
 
a.       Click Start, point to Programs, point to Administrative Tools, and then click Services.
b.      In the right pane, click Microsoft Exchange Information Store. Then, click Restart on the Action menu. If you receive a message that other services will also be restarted, click Yes.

Microsoft Technote: support.microsoft.com/kb/314605


How to Disable Circular Logging in Exchange 2007 :
   

  • To use the Exchange Management Console to disable circular logging:
1.      Start the Exchange Management Console.
2.      In the console tree, expand Server Configuration, and then click Mailbox.
3.      In the work pane, right-click the storage group for which you want to enable or disable circular logging, and then click Properties. The <Storage Group Name> Properties dialog box appears.
4.      Clear the Enable circular logging check box.
5.      Click OK.
6.      To make your changes to the circular logging settings effective, Restart the Microsoft Exchange Information Store service, or dismount and then mount all of the databases in the storage group.
 
  • To disable circular logging using Exchange Management Shell, run the following command:
Set-StorageGroup -Identity "First Storage Group" -CircularLoggingEnabled $false
 
 
 
 
 
How to Disable Circular Logging in Exchange 2010 :


 

  • To use the Exchange Management Console to disable circular logging:
1.      In the console tree, navigate to Organization Configuration | Mailbox.
2.      In the result pane, on the Database Management tab, select the database you want to configure.
3.      In the action pane, under the database name, click Properties.
4.      Click on the Maintenance tab
5.      Clear the Enable circular logging check box.
6.      Click OK
7.   To make your changes to the circular logging settings effective, Restart the Microsoft Exchange Information Store service, or dismount and then mount all of the databases in the storage group.
  • To disable circular logging using Exchange Management Shell, run the following command:
Set-MailboxDatabase -Identity "Database Name" -CircularLoggingEnabled $false

 

Microsoft Technote: technet.microsoft.com/en-us/library/dd297937.aspx#UseShelltechnet.microsoft.com/en-us/library/bb123971.aspx

 




Article URL http://www.symantec.com/docs/TECH192178


Terms of use for this information are found in Legal Notices