Authorization failure error when attempt to configure cloud storage servers for AT&T Synaptic Storage as a Service

Article:TECH192210  |  Created: 2012-07-02  |  Updated: 2012-10-09  |  Article URL http://www.symantec.com/docs/TECH192210
Article Type
Technical Solution

Product(s)

Environment

Issue



Attempts to configure cloud storage servers for AT&T Synaptic Storage as a Service fail with popup error message:
     authorization failure

The NetBackup Administration Console - Cloud Storage Server Configuration Wizard - rejects all attempts to enter valid User Name and Password combinations for AT&T Synaptic.

The User Name corresponds to a string comprising 
   vendor supplied Subtenant ID field
   a slash character (/) separator
   vendor supplied UID field

The Password corresponds to the vendor supplied SharedSecret field


Error



authorization failure


Environment



This symptom may be observed in NetBackup versions 7.5 GA through 7.5.0.4.


Cause



The NetBackup cloud plugin for AT&T invoked a getLSUList() API call to initiate credential verification and the checkAlive() API call to check if the service is alive.  It was later discovered that we can not count on the existence of an LSU on the vendor side.  The solution involves invoking the getServiceVersion() API prior to passing credentials which will accommodate new credentials which have not been previously associated with an LSU on the vendor side.  This issue will only occur the first time new credentials are validated.  The problem will not occur after credentials have been validated.

The  tpcommand log from an authorization failure will contain these markers:
<2> naidcdedup: att: [CurlRequest::headers]hd:x-emc-tags:is_lsu
<2> naidcdedup: att: [CurlRequest::headers]hd:x-emc-user-tags:lsu_name
<2> naidcdedup: att: [CurlRequest::headers]hd:x-emc-useracl:Netbackup=FULL_CONTROL
<2> naidcdedup: att: [Curl Debug]HTTP code:(404)
<16> naidcdedup: att: [Curl Debug]Error returned from atmos : The requested object was not found. (1003)
<2> naidcdedup: att: [CurlRequest::perform]check_curl_perform_result return:2060018.
<16> naidcdedup: att: [AtmosRestApi::getLSUList]curl_->perform:2060018.
<16> naidcdedup: att: [stspi_open_server]Error:2060018 occurs when check credential.
<16> naidcdedup: libsts opensvh() 12/06/07 15:24:39: v11_open_server failed in plugin C:\Program Files\Veritas\NetBackup\bin\\ost-plugins\libstspiatt.dll err 2060018
...
<16> naidcdedup: libsts opensvh() 12/06/07 15:24:39: v11_open_server failed in plugin C:\Program Files\Veritas\NetBackup\bin\\ost-plugins\libstspigateway.dll err 2060018
<16> Valid_STS_Server: Failed to open server connection to type att_raw server storage.synaptic.att.com: Error = 2060018 file not found


Solution



The formal resolution to this symptom will be available in the NetBackup 7.5.0.5 Maintenance Release.

Emergency Engineering Binaries (EEBs) are available from Technical Support for installation on top of NetBackup 7.5.0.3 and 7.5.0.4 Maintenance Releases.  To obtain an EEB, contact Technical Support and reference:
     NetBackup 7.5.0.4 - ET2943386
     NetBackup 7.5.0.3 - ET2936751


Supplemental Materials

SourceETrack
Value2943386
Description

Unable to create ATT cloud storage server via wizard


SourceETrack
Value2936751
Description

Unable to creatae ATT cloud storage via wizard



Article URL http://www.symantec.com/docs/TECH192210


Terms of use for this information are found in Legal Notices