The attempt to display and select Lotus Domino selections hangs indefinitely.

Article:TECH192313  |  Created: 2012-07-03  |  Updated: 2012-07-03  |  Article URL http://www.symantec.com/docs/TECH192313
Article Type
Technical Solution


Issue



When using the Lotus Domino agent for Backup Exec, the Lotus Domino databases are displayed beneath an icon called 'Lotus Domino Databases'.  Expanding that icon shows selections for each volume contained on the server displayed as 'Databases on servername|X:'  where X is the drive letter.  When you expand and attempt to display the databases contained on one of the volumes present you will receive a popup that this action will scan, discover, and verify Domino databases.  This enumeration process can take a long time - up to an hour normally but this technote describes an issue where the attempt to view Domino databases hangs indefinitely.


Environment



This issue can involve any supported version of Lotus Domino server that has been upgraded or updated in some way.


Cause



An upgrade to the Domino server software may result in older version Domino DLLs being left behind that the Backup Exec Lotus Domino agent attempts to use in communicating with Domino Server.

There are multiple Domino server DLLs that the Backup Exec Domino agent depends on to make an API connection to the Domino server.  If the Backup Exec Domino agent tries to use outdated or incorrect-versioned DLLs to make this connection it may hang. The DLL files are normally read from the Lotus Domino binaries folder which is typically X:\...Lotus\Domino\ but the Windows environment variable 'Path' is also followed in searching for these DLL files.

Example:  Lotus Domino is installed in d:\Lotus\Domino and has a copy of NNOTES.DLL located in that folder.  The c:\windows\system32 folder also has a copy of NNOTES.DLL that is an earlier version.  Since this older file is in the system Path, it may be used by the Backup Exec Remote Agent for the API connection to Domino server and fail.  The file in the c:\windows\system32 folder needs to be made unavailable to the Remote Agent.


Solution



Following the NOTES below, locate all copies of the following DLLs on the Domino server and rename those with an extension of 'old' that are not consistent with the installed version of the Domino server:
NNOTES.DLL
JS32.DLL
NLSCCSTR.DLL
NXMLPROC.DLL
NDGTS.DLL
NSTRINGS.DLL

NOTE: These DLLs are used by beremote.exe during Backup Exec Remote Agent service startup.  To confirm what DLLs beremote.exe is using, a file system monitoring utility such as Microsoft's Process Monitor or File Monitor.  See http://technet.microsoft.com/en-us/sysinternals for these utilities. Monitor the attempt to browse the Lotus Domino databases and watch the locations of each of the DLL files the Remote Agent processes beremote.exe or belnapi.exe read.

IMPORTANT:  It is common for the Lotus Notes or the Domino Administrator applications to be present on the Domino server.  Some of these same named DLLs may be present for these applications.  These files are commonly located in X:\...Lotus\Notes folder.  These DLLs should never be renamed.




Article URL http://www.symantec.com/docs/TECH192313


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