Failed to apply license key - VCS ERROR V-16-1-40211 [Licensing] Unable to set base path [ret = 90]
| Article:TECH192363 | | | Created: 2012-07-04 | | | Updated: 2012-07-09 | | | Article URL http://www.symantec.com/docs/TECH192363 |
Problem
The license key is accepted from the license management wizard but is not showing up in "C:\Program Files (x86)\Common Files\VERITAS Shared\vrtslic\lic." The Command line tools vxlicrep or vxlicinst error with license key directory not found.![]()
![]()
![]()
Error
Engine_A log
2012/07/01 14:59:01 VCS ERROR V-16-1-40211 [Licensing] Unable to set base path 'C:\Program Files\Common Files\VERITAS Shared\vrtslic' for licensing framework [ret = 90]
2012/07/01 14:59:01 VCS ERROR V-16-1-52571 [Licensing] Unable to initialize the licensing framework (Remote Build)
VPITrace
[2012/07/02 13:30:48 VPI DBG_6 V-16-12-0 vpihelper.cpp:helperRegistreLicenseKey:3302] Failed to update License Key XXXX-XXXX-XXXX-XXXX-XXXX-XXXX with Error=9
Error =9
ERROR_INVALID_BLOCK winerror.h
# The storage control block address is invalid.
vxclicinst.exe - V-21-1-61 - Initialization failed: License key directory does not found. Please install VRTSvlic package.
vxlicrep.exe - V-21-3-1003 - There are no valid VERITAS License keys installed in the system.
Environment
Windows 2003/2008 x64/ IA64
Cause
The 32bit CommonProgramFiles environment variable somehow changed from “C:\Program Files (x86)\Common Files” to “C:\Program Files\Common Files”. This caused VCS engine to fail trying to locate the license folder that VPI created at “C:\Program Files (x86)\Common Files”. The engine was looking for the path at “C:\Program Files\Common Files”. It determines that path by looking at following registry value "CommonFilesDir" : HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Windows\CurrentVersion

Solution
- Open regedit
- Goto HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion
- In the attribute "CommonFilesDir" and "CommonFilesDir (x86)" make sure it is set to "C:\Program Files (x86)\Common Files"
- Close and reboot
|
|
|
|
Article URL http://www.symantec.com/docs/TECH192363
Terms of use for this information are found in Legal Notices









Thank you.