Incident from e-mail monitor is created without a contact.
| Article:TECH192422 | | | Created: 2012-07-05 | | | Updated: 2012-07-10 | | | Article URL http://www.symantec.com/docs/TECH192422 |
Problem
An incident that is created from e-mail using SD.Email.Monitor may be created with no Contact(s) being shown in Incident.
This happens when e-mail address the e-mail came from is not a ServiceDesk user but is contained in an e-mail address that is a ServiceDesk user. For example an e-mail comes from support@domain.com that does not have a corresponding ServiceDesk user but there is a ServiceDesk user with itsupport@domain.com e-mail address.
Environment
ServiceDesk 7.1 SP1
ServiceDesk 7.1 SP2
Cause
This happens due to Search User component searching for users using 'contains' search, not a search for an exact match. Specifically 'Search User (by email address) [2.10]' component in ProcessMessage model. No further check is done in the workflow whether the correct user(s) was/were found.
In the example from above, search for support@domain.com results in users being found, as that string is contained in itsupport@domain.com and incident is created with support@domain.com as a contact incorrectly assuming that it is a ServiceDesk user. This causes contact to not show up when Incident is viewed and other potential issues down the line.
Solution
Symantec is aware of and is looking into the issue.
WORKAROUND:
Issue can be worked around by customizing the SD.Email.Monitor workflow. The list of steps below is one way of doing this, there are other possible ways.
- Add a Configurable Collection Filter component on the Found path out of Search User (by email address) [2.10] component.
- Configure it to work on User Data Type and UsersList Array Variable.
- Insert a Text Equals Rule component in the Filter Model to compare Element.PrimaryEmail with FromAddress. Connect equals output to Keep Value and not equals to Filter Out Value
- Add a Equals Rule component after Configurable Collection Filter and configure it to compare Number (integer) Data Type and Variable Name UsersList[].Count to Constant Value 0.
- Connect the output paths from Equals Rule component:
- not equals: to the next component on the original 'Found' path (Get User Info in 7.1 SP2 version)
- equals: to the next component on the original 'Not Found' path (Set User Info - Guest User in 7.1 SP2 version)
|
|
| Value | 2117094 |
| Description | When using the Search user(userman) it does a LIKE return of users and SD needs to filter out to the exact email required. |
| Source | ETrack |
| Value | 2844947 |
| Description | When using the Search user(userman) it does a LIKE return of users and SD needs to filter out to the exact email required. |
Article URL http://www.symantec.com/docs/TECH192422
Terms of use for this information are found in Legal Notices









Thank you.