Storage Foundation for Windows shows Missing Disks with Unknown Disk Group in the Veritas Enterprise Administrator interface

Article:TECH192755  |  Created: 2012-07-11  |  Updated: 2012-07-21  |  Article URL http://www.symantec.com/docs/TECH192755
Article Type
Technical Solution


Issue



When opening the Veritas Enterprise Administrator interface that is part of the Storage Foundation for Windows installation, Dynamic or Cluster Dynamic Disk Groups may show Missing Disks while the interface displays a listing for UnknownDG (Unknown Disk Group).

 


Cause



When placing disks under the management of Storage Foundation for Windows, this enterprise application will create a Private Region on the disk. This Private Region is roughly 1 MB in size and the location on the disk can vary between GPT and MBR disks. This Private Region is a proprietary file that maintains up to date information regarding the disks in Dynamic or Cluster Dynamic Disk Group managed by SFW, as well as the number of disks, and volumes in that disk group.

All disks in the disk group are provided a copy of the Private Region and this is updated between all disks whenever an action is performed on the disk group by any server that has had these disks presented to it.

When a Private Region in the disk group is not properly updated for any reason, the issue described above is encountered and the disk group displays Missing Disks with an UnknownDG (Unknown Disk Group) in the VEA interface. This does not necessarily mean the disks are physically missing. Instead, SFW will place the Missing Disk entries in the disk group as place holders to alert the server administrator that there is a problem with these specific disks, while viewing the UnknownDG will show those disks listed.

 


Solution



In these specific circumstances, Symantec Support will typically be needed in order to review the issue and confirm the best steps for resolution.

As a general rule, this type of problem can come about for a number of different reasons ranging from a hardware outage on the disks to an issue with the disk group itself. Symantec Support carries proprietary tools that will allow for troubleshooting the issue for resolution in order to bring these disks back into proper working order. At that point, it can be determined, based on the events the preceded the issue, what preventative steps may need to be taken to ensure future stability.




Article URL http://www.symantec.com/docs/TECH192755


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