How do we troubleshoot DeployAnywhere (DA)?

Article:TECH193496  |  Created: 2012-07-23  |  Updated: 2012-09-04  |  Article URL http://www.symantec.com/docs/TECH193496
Article Type
Technical Solution

Product(s)

Issue



 We're having problems getting our drivers to work.  What can be done?


Cause



KNOWN ISSUE: DeployAnywhere with DS 7.1 does not always apply the drivers needed.
http://www.symantec.com/docs/HOWTO79452 
 


Solution



Below is a lot of information on the internal functionality of DeployAnywhere (DA) that may assist in either resolving, or at least understanding, the behavior of DeployAnywhere.  Please use this information against what you're seeing to ensure you take proper action in adding drivers to DA.

Definitions:

Critical Drivers = NIC and Mass Storage Drivers.  These are deemed critical because without them, the system is considered non-functional.  Without Mass Storage, it may not boot.  Without NIC, you may not be able to reach it and/or perform any updates to it, so these are deemed critical.

Non-Critical Drivers = Anything else, such as Video, Sound, etc.  All of these drivers can be added after-the-fact through various methods so long as the system is bootable and accessible via Critical drivers.

Driver Matching: Rank

When DA looks at drivers, it looks for a number of things, tries to find any / all matches possible, and then makes a ranked choice of what driver to use.  Here are some important items to note about driver selection (highest rank wins):

  • DA looks at drivers in our Database AND drivers available to Windows on the target system.
  • Native Windows drivers always gets a higher rank in the event of an equal match (tie) with one from the Database.
  • DA looks for a "full match" of data in the inf file which includes Vendor, Device, and SubSystem ID's.  This is called a "Best Match" and has the highest rank.  Information similar to this can be found under Device Management in Windows under the properties for the device under Hardware ID's.
  • DA will also look for partial matches of the Best Match where only one part of the full device ID matches (e.g. only one of the fields).  This is considered a "Compatibility Match".  Information similar to this can be found in the production OS for loaded devices under Compatible ID's in Device Management.
  • In the event of a tie (multiple drivers match), several things are considered:
    • Native Windows drivers always win (see bullet above)
    • Drivers with CAT files get next priority
    • Latest version gets next priority in the event of two or more having CAT files.

DA Switches of note:

Switch Function
/Managed  This tells DA to output results to a "driver_list.txt" file.  Note, output to this file can be extensive depending on the switches used.
/Eval  Requires /Target.  This tells DA not to actually re-target anything, but simply to look for missing drivers.  It may be used with or without the /DDB switch.  If used with /ddb, then it looks for drivers missing from the Drivers DB.  If used without it, it looks for drivers mssing from the target OS.
/Precheck  This tells DA to enumerate all devices that require drivers and check if those drivers are present in the database.  NOTE: it does NOT check for drivers present in the target OS like the /eval switch does.  /Precheck can also be used with a /ddb switch (which also would require a /target switch).  It can also be used with /reportnoncriticaldevices for an expanded output of results.
 /ReportNonCriticalDevices  This will expand the output of DA to include non-critical devices to the logs.
   
   
   
   
   
   
   
   
   
   

 




Article URL http://www.symantec.com/docs/TECH193496


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