The manual registration of Backup Exec using "BeUpdateOps.exe -AddBE -OptOut" fails with "Failed to register Backup Exec with LiveUpdate with an error code of 1603 -Now Exiting".

Article:TECH194565  |  Created: 2012-08-07  |  Updated: 2012-08-07  |  Article URL http://www.symantec.com/docs/TECH194565
Article Type
Technical Solution

Product(s)

Issue



The manual registration of Backup Exec using "BeUpdateOps.exe -AddBE -OptOut" fails with "Failed to register Backup Exec with LiveUpdate with an error code of 1603 -Now Exiting". (Figure 1)

Figure 1


Error



Failed to register Backup Exec with LiveUpdate with an error code of 1603 -Now Exiting


Environment



Backup Exec 2010 R2 (However, the issue does not depend on the specific versions.)
LiveUpdate 3.3


Cause



In case of x64, one or some of the following files might be corrupted. This issue occurs even if one of them is corrupted.

C:\ProgramData\Symantec\Backup Exec\{DD8FD4D3-F0FB-4FB2-8A34-25E2C7756A51}\Media\Bin
LUShim.exe
LUShimPS32.dll
LUShimPS64.dll 

C:\Program files (x86)\Symantec\LiveUpdate\

Alunotify.exe
LuCallBackProxy.exe
LuComServer_3_3.exe

Ludirloc.dat
LuPrecon.dll

ProductRegCom_3_3.dll
PSLuComServer_3_3.dll
ResLuComServer_3_3.dll
UNRAR.DLL


Solution



If there is a system that LiveUpdate of the same version works correctly on, please copy the above files from the system to problematic one and rerun "BeUpdateOps.exe -AddBE -OptOut".




Article URL http://www.symantec.com/docs/TECH194565


Terms of use for this information are found in Legal Notices