Bad or missing PXE menu due to PXE Menu being overloaded

Article:TECH195525  |  Created: 2012-08-23  |  Updated: 2012-08-23  |  Article URL http://www.symantec.com/docs/TECH195525
Article Type
Technical Solution

Issue



After creating a new Preboot Configuration within an environment which was previously working, the client machines which were attempting to boot into WinPE were unable to do so due to the following error message:

PXE-E74: Bad or missing PXE menu and/or prompt information

 


Error



 PXE-E74: Bad or missing PXE menu and/or prompt information


Environment



 Deployment Solution 7.1 SP1a


Cause



It was confirmed that the PXE Menu had been overloaded with the available Preboot Configurations. Unfortunately, deleting the extra Preboot Configurations which were overloading the PXE Menu did not resolve the issue. It was discovered that these deleted Preboot Configurations were still being picked up by the SBS image files. It was discovered that the Preboot Configurations which had been deleted were still being listed in the Inv_PXE_Image_List table.


Solution



To resolve the issue first run the following SQL Query to confirm whether the deleted Preboot Configurations are still being listed in the Inv_PXE_Image_List table:

 

select px.Path, px.Description, vc.Name 

from Inv_PXE_Image_List px

join vComputer vc on vc.Guid = px._ResourceGuid

 

Once you have identified the offending Preboot Configuration execute the following SQL Query to delete the entries:

 

DELETE from Inv_PXE_Image_List 

WHERE Description in ('Name of Preboot Configuration')

 

Finally, stop all of the PXE services on the SMP and then delete all of the files from the InstallDir:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\SBS\SBSStore directory and then restart the PXE Services in the correct order.




Article URL http://www.symantec.com/docs/TECH195525


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