Nukona Error: "provisioning profiles do not match"

Article:TECH195757  |  Created: 2012-08-28  |  Updated: 2012-11-26  |  Article URL http://www.symantec.com/docs/TECH195757
Article Type
Technical Solution


Issue



When trying to upload an updated .ipa file for an app already on the Nukona Appcenter, the error "provisioning profiles do not match" is displayed and the process is aborted.


Error



Error "provisioning profiles do not match".


Environment



This applies to version 3.0 and 3.1 of Nukona App Center.

RHEL/CentOS 5.5-5.8 64-bit.

Xcode 4.4.1.


Cause



In Xcode, there are two options for a certificate to be chosen for app code signing. One is for the code signing certificate under the build settings and the other is for the .ipa file export process. Matching code signing certificates are not automatically selected if there are more than one of them imported into Xcode. This issue will occur when the code signing certificates do not match in both configuration dropdowns upon app creation.

 


Solution



Ensure that the code signing certificate used in the app's build settings under the certificate dropdown matches the one listed in the same dropdown listed during the .ipa export process.

 




Article URL http://www.symantec.com/docs/TECH195757


Terms of use for this information are found in Legal Notices