Upgrading Control Compliance Suite (CCS) generates error: Data migration for all the CCS applications is not complete.

Article:TECH195949  |  Created: 2012-08-31  |  Updated: 2012-08-31  |  Article URL http://www.symantec.com/docs/TECH195949
Article Type
Technical Solution


Issue



While upgrading CCS with Update (PCU), the installer generates an error 'Data migration for all the CCS applications is not complete' and upgrade fails with rollback even though all previous CCS migrations completed successfully.

 


Error



 


Environment



CCS Build: >= 10.0.863.10000


Cause



PCU installer checks to verify that migration is complete for all CCS applications. This check was failing because there were two records in UserMgmt_SecurityPrincipals.SID that were returning NULL values.

To verify that this is the issue, the following query must return records with NULL values in (Microsoft SQL Server Management Studio) Results view:

USE CSM_DB
SELECT policy.UserResponse.UserNetworkID, UserMgmt_SecurityPrincipals.SID FROM policy.UserResponse
LEFT JOIN UserMgmt_SecurityPrincipals ON
policy.UserResponse.UserNetworkID = UserMgmt_SecurityPrincipals.SID
WHERE UserMgmt_SecurityPrincipals.SID IS NULL

 


Solution



To resolve this issue use the following steps to manually update SID values:

1. Open Microsoft SQL Server Management Studio

2. Select New Query

3. Cut/Paste the following SQL script:

USE CSM_DB
INSERT INTO UserMgmt_SecurityPrincipals (SID, DisplayName, SAMAccountName,Type, LastUpdatedOn, IsDeleted, UDMID, MailID)
SELECT USERS.UserNetworkID , USERS.UserName, USERS.UserName, 1, GETUTCDATE(),0, NEWID() , ''
FROM ( select distinct U.UserNetworkID , U.UserName FROM policy.UserResponse U
LEFT JOIN UserMgmt_SecurityPrincipals S on U.UserNetworkID = S.SID where S.SID is null ) USERS

4. Execute the query (completing successfully)

5. Upgrade CCS to latest Update (PCU)

 




Article URL http://www.symantec.com/docs/TECH195949


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