Windows 8 System Does Not get an IP Address After Removing the SNAC Client.
| Article:TECH196260 | | | Created: 2012-09-06 | | | Updated: 2012-09-14 | | | Article URL http://www.symantec.com/docs/TECH196260 |
Problem
If an 802.1x authentication that fails, and the "Wired AutoConfig" service is stopped, the network connection will remain frozen in an "unauthenticated" state.
This issue was reproduced on Windows 8 x_64 and has been reproduced without SNAC/EAP installed.
Error
System unable to aquire and IP address.
Environment
OS: Windows 8 x_64
Cause
Based lab research, Symantec does not believe this is issue is caused by the SNAC product. On a client system two settings to control the 802.1x authentication:
- "Wired AutoConfig" service status
- "Enable IEEE 802.1x authentication" checkbox in the network properties
By default, the "Wired AutoConfig" service is not running, and the "Enable IEEE 802.1x authentication" is checked. When the service is started in this configuration, the
properties page will show that it is enabled (checked). If the SNAC agent is uninstalled, the "Wired AutoConfig" service is also stopped. Because the "Enable IEEE 802.1x authentication" is NOT changed by SNAC, the setting will not be updated.
In lab tests, when the "WireAutoConfig" is stopped, the adapter is left in an "unauthenticated" status. When you uncheck the "Enable IEEE 802.1x authentication" it informs the network adapter to exit the "unauthenticated" state, causing the NIC to be unable to get an IP address.
Solution
Workarounds include:
Starting the "Wired AutoConfig" service + pass the 802.1x authentication
or
Start the "Wired AutoConfig" service
Uncheck the "Enable IEEE 802.1x authentication" in the network connection property page
Then stop the "Wired AutoConfig" service.
Please see the attached "802.1x.PNG" for detail.
Attachments
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Article URL http://www.symantec.com/docs/TECH196260
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