KNOWN ISSUE: Patches are installing outside of their scheduled window, when machines come out of hibernation
| Article:TECH196322 | | | Created: 2012-09-07 | | | Updated: 2012-09-07 | | | Article URL http://www.symantec.com/docs/TECH196322 |
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Problem
Patches are installing outside of their maintenance window, when machines come out of hibernation and the agent has been upgraded.
We noticed that the client policy.xml for the problem systems shows the schedule in a different format that if the agent was a clean install and not an upgrade.
Environment
Symantec Management Platform 7.1 SP2 + Rollup v4
Cause
Known Issue.
This problem is caused by Agent's schedule engine. After recovering from hibernate mode it thinks that scheduled event had passed and should be processed and throws Software Update Application task to the Patch plug-in which triggers software update cycle.
Solution
This issue has been reported to the Symantec Development team. A fix will be provided in our next release (currently targeted for SMP 7.1 SP2 MP1 and ITMS 7.5)
A pointfix is available for this issue.
For SMP 7.1 SP2, please see attached "Pointfix_eTrack2747171.zip"
For SMP 7.1 SP2 with Rollup v4, please see attached "Pointfix_eTrack2873369.zip"
HOW TO INSTALL THIS POINTFIX:
1. Extract files from the "Pointfix_eTrack2747171.zip" or "Pointfix_eTrack2873369.zip" archive (depending on what version you have installed) to the NS hard drive. Make sure PointFix is not extracted to Altiris install directory (or any subfolder to it).
2. Execute PFInstaller.exe with administrative privileges (right-click > Run as administrator).
3. Accept UAC (User Account Control) prompt, select Install Files. Old binaries will be automatically backuped to the Backup folder at the same location where PFinstaller is and replaced with the new ones. Log-file Log.txt will be created at the same location where PFinstaller is.
4. Close PFInstaller window.
CHANGES MADE:
For exact triggers, added check to ensure that current time is fit into scheduled window.
THIS HOTFIX HAS THE FOLLOWING KNOWN ISSUES:
None.
HOW TO UNINSTALL THIS POINTFIX:
1. Make sure that Backup subfolder is located in PFinstaller’ directory
2. Execute PFInstaller.exe with administrative privileges (right-click > Run as administrator). Old binaries will be repaired from Backup folder located at the same location where PFinstaller is. NS services should be started automatically
3. Accept UAC (User Account Control) prompt), select Uninstall Files.
4. Close PFInstaller window.
Attachments
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| Source | ETrack |
| Value | 2747171, 2873369 |
Article URL http://www.symantec.com/docs/TECH196322
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