Recovery Solution in Workgroup environment

Article:TECH19635  |  Created: 2006-09-18  |  Updated: 2008-09-24  |  Article URL http://www.symantec.com/docs/TECH19635
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution

Issue



I am unable to register Recovery Solution Agent on non-domain computers as there are no domain credentials available.


Cause



Non-domain units are not able to leverage domain accounts to facilitate registration of the Recovery Solution Agent.

Solution



Important: This workaround is in testing. Results of following this procedure are potentially hazardous in some environments. Proceed at own risk.

In order to allow for the registration of the Recovery Solution agent on non-domain computers, an account must be provided to allow for the registration and subsequent usage of the Recovery Solution facilities. In this case, a local account on the Recovery Solution Server itself will permit this. In order to attempt this workaround, follow these steps:

  1. Create a local account on the Recovery Server. No particular rights are required other than the default User privileges.
    • If Recovery Solution and Notification Server are on the same server, then on the Cluster Users configuration (Configuration > Solutions Settings > Incident Management > Recovery Solution > Recovery Solution Clusters > Recovery Solution Clusters Configuration > %CLUSTER% > Users) add the local account to the RS_Users.
    • If Recovery Solution and Notification Server are on different servers, then on the database server, open Enterprise Manager (or SQL Server Management Studio if SQL 2005). Open AexRSDatabase (or equivalent Recovery Solution database) and edit the LocalGroupMembers table and add the newly created account using the {COMPUTERNAME}\{USERID} format and set the GroupType to 0
  2. Set the Recovery Solution Agent Install package line to use the following command line string

    agentsetup.exe /server:[RS Server Name] /user:[Local Account Name on RS Server] /pass:[password] /domain:[RS Server Name]

  3. Reboot the Recovery Server.
  4. Enable the Recovery Solution Install policy.

Legacy ID



27456


Article URL http://www.symantec.com/docs/TECH19635


Terms of use for this information are found in Legal Notices