KNOWN ISSUE: Computers view takes over 20 seconds to render when last selected item is a parent folder

Article:TECH196428  |  Created: 2012-09-10  |  Updated: 2012-09-10  |  Article URL http://www.symantec.com/docs/TECH196428
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Article Type
Technical Solution


Issue



Working with a customer we found that if a user selects one of the parent items under Manage>Computers>All Computer Views that next time they load the SMP Console, it fails to render for about 20 seconds or no render the all (sometimes causing the Internet Explorer Browser to crash). 

It may be noticed by customers with a large AD Import structure or large Organizational Groups and Views with many sublevels.


Environment



Symantec MAnagement Platform 7.1 SP2


Cause



Known Issue. Investigating the code, Dev found that we never actually check to see if the last selected item is a parent folder, we automatically start traversing the tree looking at the children only.  This causes the client to unnecessarily traverse ALL trees in the view, when the last selected item is simply the parent.


Solution



This issue has been reported to the Symantec Development team. A permanent fix will be provided in a later release (currently targeted for SMP 7.1 SP2 MP1 and ITMS 7.5)

A pointfix for this issue is available. See "ComputerView.zip" attached to this article.

Steps to install:

1. Go to Star and under 'search' type Silverlight. Open it. It should open the Microsoft Silverlight Configuration page.
2. Go to 'Application Storage' tab
3. Under the 'Web site' column, click on 'Delete all'. It should clear out the local cache that Silverlight uses to populate the views used in the SMP Console
4. Download the attached "ComputerView.zip" and extract the file "ComputerView.xap"
5. Go to ...\Program Files\Altiris\Activity Center\Web\ClientBin and rename the "ComputerView.xap" and move it away from this folder
6. Place the new "ComputerView.xap" file and reopen the SMP Console

This pointfix should address partially the issue of traversing the tree looking at the children only. If you select something down this "All Computer Views" tree, then the issue will reappear when you go back to Manage>Computers. The quick way to get back functionality is to repeat the steps 1-3 above.


Attachments

ComputerView.zip (714 kBytes)

Supplemental Materials

SourceETrack
Value2786821


Article URL http://www.symantec.com/docs/TECH196428


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