Failed to configure NS. Failed to create a Scripting.FileSystemObject.object. Error: Activex component can't create object: 429

Article:TECH196497  |  Created: 2012-09-11  |  Updated: 2012-09-11  |  Article URL http://www.symantec.com/docs/TECH196497
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution


Issue



Customer is having an issue trying to install the Symantec Management Platform (SMP). When Symantec Installation Manager (SIM) is in the process of installing MSIs, the following error window popups almost at the beginning of this process:

Failed to configure NS.
Failed to create a Scripting.FileSystemObject.object.
Error: Activex component can't create object: 429

After that, the customer is not able to finish the installation.


Error



Failed to configure NS.
Failed to create a Scripting.FileSystemObject.object.
Error: Activex component can't create object: 429


Environment



Symantec Installation Manager 7.1.206
Symantec Management Platform 7.1 SP2


Cause



This issue is caused by an unregistered dll called scrrun.dll. It is not caused by our installation process.


Solution



Please try the following steps to resolve this issue:

1. Download and extract the file called "copyfile.zip"
2. Double-click on "copyfile.vbs". It is a vbscript that will make a copy of the file called Test.txt. A new file will be created called Test2.txt. This vbscript basically calls the same "Scripting.FileSystemObject" object as the installation error mentions.
3. What we are expecting is that you will not be able to run the vbscript without getting the same error message as the installation one. You should not see a new file created. If that is the case, the issue is with your system.
4. If you get the same error, please try the following:
a) Open a Command Prompt by clicking on the Start button, and selecting Run, and typing "command" and pressing Enter.
b) Change to the "C:\Windows\syswow64" directory.
c) Enter the following command:
    regsvr32 scrrun.dll
and press Enter.
5. Retry the  "copyfile.vbs" and see if now you are able to run it and create the new file as expected. If so, please try to install SMP again.


Attachments

copyfile.zip (405 Bytes)

Supplemental Materials

SourceETrack
Value2917739


Article URL http://www.symantec.com/docs/TECH196497


Terms of use for this information are found in Legal Notices