Windows System Assessment Scan fails with Exit Code 7
| Article:TECH196681 | | | Created: 2012-09-14 | | | Updated: 2012-09-17 | | | Article URL http://www.symantec.com/docs/TECH196681 |
Problem
The scheduled Windows System assessment scan for PatchManagement Fails with Exit code 7
Error
Exit Code 7 - Cannot send inventory

Environment
Client - Windows Server 2008 R2
Cause
Incorrect installation of SMP agent on Client computer
Solution
Please review the following steps and verify that you have a similar issue.
Try to manually run the file from the following path.
C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{6D417916-467C-46A7-A870-6D86D9345B61}\cache
Filename: AexPatchAssessment.exe

1. Verify the correct installation path of SMP agent installed on Client computer.
2. Verify that Queue folder exists i.e. C:\Program Files\Altiris\Altiris Agent\Queue
3. Verify that the following regkey has to correct value
HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\Altiris Agent\Transport\Queue Path
Value: C:\Program Files\Altiris\Altiris Agent\Queue
In our case, customer had an Older version of Altiris Ver6 still installed on the Server in the following directory.
C:\Program Files (x86)\Altiris\Altiris Agent\
Since correct SMP agent version i.e. 7.1 SP2 agent was installed within C:\Program Files\Altiris\Altiris Agent\ except for inventory agent, we cleared out all files and directories from
C:\Program Files (x86)\Altiris\Altiris Agent\ leaving ONLY C:\Program Files (x86)\Altiris\Altiris Agent\Agents\inventory Agent (as this is a valid folder)
Having incorrect files & reference in Registery was causing agent not to process information correctly.
After removing older files, we restarted SMP agent and ran Windows Assessment scan and it returned a success code.

Related KBs
Title: Windows Assessment Scan Error Codes
http://www.symantec.com/docs/TECH179849
Title: Windows System Assessment Scan fails with Exit Code 6
http://www.symantec.com/docs/TECH182272
Title: Windows System Assessment Scan displays failed with Exit Code 3
http://www.symantec.com/docs/TECH185079
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Article URL http://www.symantec.com/docs/TECH196681
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