Java LiveUpdate (JLU) return code -2,001, "The Java LiveUpdate session did not complete successfully."

Article:TECH197202  |  Created: 2012-09-25  |  Updated: 2013-01-14  |  Article URL http://www.symantec.com/docs/TECH197202
Article Type
Technical Solution


Issue



Symantec Mail Security for Domino  8.x on Windows failed to update AntiVirus definitions with the following errors.


Error



17-set-2012 17.40.58 An active JLU session has been detected.
17-set-2012 17.40.58 JLU was able to successfully connect to its own listener thread.
17-set-2012 17.40.58 Downloading minitri.flg to C:\ProgramData\Symantec\Java LiveUpdate\Downloads\1347896458226\minitri.flg ...
17-set-2012 17.40.59 This session of JLU has been aborted by the caller.
17-set-2012 17.40.59 Downloading livetri.zip to C:\ProgramData\Symantec\Java LiveUpdate\Downloads\1347896458226\livetri.zip ...
17-set-2012 17.40.59 Downloading minitri.flg to C:\ProgramData\Symantec\Java LiveUpdate\Downloads\1347896458226\minitri.flg ...
17-set-2012 17.40.59 Downloading livetri.zip to C:\ProgramData\Symantec\Java LiveUpdate\Downloads\1347896458226\livetri.zip ...
17-set-2012 17.40.59 Downloading minitri.flg to C:\ProgramData\Symantec\Java LiveUpdate\Downloads\1347896458226\minitri.flg ...
17-set-2012 17.40.59 Downloading livetri.zip to C:\ProgramData\Symantec\Java LiveUpdate\Downloads\1347896458226\livetri.zip ...
17-set-2012 17.40.59 A LiveUpdate server could not be selected.
17-set-2012 17.40.59
17-set-2012 17.40.59 The Java LiveUpdate session did not complete successfully.
17-set-2012 17.40.59 Return code = -2.001
17-set-2012 17.40.59
17-set-2012 17.41.00 IdsEncodingFailed
17-set-2012 17.41.00 IdsCheckJCEPolicyFiles
17-set-2012 17.41.00 IdsEncodingFailed
17-set-2012 17.41.00 IdsCheckJCEPolicyFiles

Environment



Windows Server 2008 R2 Standard 64-bit Service Pack 1

IBM Lotus Domino Server 8.5.2 FP2 64-bit

Java LiveUpdate 3.9

Symantec Endpoint Protection 12.x


Cause



Some temporary and lock files are still in the File System and access to them can be denied.


Solution



Check if the following files are still in the file system.

C:\Windows\Temp\Jlu.Session.End.dat
C:\Users\<Current User>\AppData\Local\Temp\Jlu.Session.End.dat
C:\ProgramData\Symantec\Java LiveUpdate\tmpjluXXXXX.lck
 

NOTE: The tmpjluXXXXX.lck file has numbers in the files name in place of the 'X'.

If the files are there, you can safely delete them and launch LiveUpdate manually. You can do it from the Symantec Mail Security for Domino console by clicking on the Run LiveUpdate Now button that is available in the top bar when you browse to the LiveUpdate, Basics tab.





Article URL http://www.symantec.com/docs/TECH197202


Terms of use for this information are found in Legal Notices