Unable to log into the management server: SCSP server service keeps stopping.

Article:TECH197410  |  Created: 2012-09-27  |  Updated: 2012-09-27  |  Article URL http://www.symantec.com/docs/TECH197410
Article Type
Technical Solution


Problem



Unable to log into the management server: SCSP server service keeps stopping.


Error



There are no apparent errors. However, looking at the logs in the "tomcat" folder on the Windows 2008 management server under the "logs" folder, there is a log file named "sis-server.0.log" with the following error messages:

408 2012-09-16 12:38:28.021 [INFO ] [Timer-1:63] Performing database cleanup...
409 2012-09-17 11:38:28.026 [INFO ] [Timer-1:63] Performing database cleanup...
412 2012-09-18 10:38:28.029 [INFO ] [Timer-1:63] Performing database cleanup...
1890 2012-09-19 09:38:28.029 [INFO ] [Timer-1:63] Performing database cleanup...
77 2012-09-20 00:36:26.699 [INFO ] [StartupServlet:1] Critical System Protection Server is starting
4753 2012-09-20 00:43:48.110 [ERROR] [StartupServlet:1] Server initialization has failed!!
java.lang.Exception: Failed to connect to database after trying 20 times, please start the database!!

Environment



Three Windows 2008 management servers all connecting to the same SQL database.


Cause



The Windows 2008 management server was unable to connect to the SQL  database because the IPEC configuration was mis-configured.

Here is a test you can use to connect to the database using OSQL.
 
Below are the instructions for running this test:
 
This is a simple database connectivity test. Can you access the database using normal SQL tools such as OSQL on the remote machine that is intended to be the manager?
 
For example:
OSQL –S <hostname or ip address as specified in server.xml>\<instance name as specified in server.xml> -U scspdba –P <password>
 
Sample Connection string:
OSQL –S testhost\scspdb –U scspdba –P test
(Of course, if you used a different instance name than mentioned above, you can make the appropriate substitute)
 
If OSQL connects without any errors, then it means that you have a connection from the manager to the database's instance. If the test is NOT successful than there is a

connectivity problem between the tomcat server and the database machine that must be resolved.


Solution



Modifying the IPSEC configuration to the correct values resolved the communication issue to the SQL database.




Article URL http://www.symantec.com/docs/TECH197410


Terms of use for this information are found in Legal Notices