Hotfix for Symantec Enterprise Vault (EV) for File System Archiving (FSA) 9.0 Service Pack 4, Build 1097, File server unresponsive in a hung state following PH recall. Reset required
| Article:TECH197715 | | | Created: 2012-10-02 | | | Updated: 2013-02-04 | | | Article URL http://www.symantec.com/docs/TECH197715 |
Problem
Which version of Symantec Enterprise Vault (tm) can this hotfix be applied?
This hotfix can only be applied to the following versions of Enterprise Vault for:
Enterprise Vault for File System Archiving 9.0 Service Pack 4, Build 1097
Cause
FSA Driver deadlocks with Cache Manager when the file is recalled as part of read-ahead mechanism of Cache Manager.
A PAGING I/O is seen in a recall case which was not expected from an FSA Driver perspective.
Solution
What issue(s) does this hotfix resolve?
FSA Driver (evmf.sys) now checks for IRP_PAGING_IO flag in the IO Parameter Block (Iopb->IrpFlags), and a new deferred-I/O work item is created and inserted into the deferred I/O work queue to avoid the deadlock.
Which files does this hotfix replace?
| File Name | File Version | New File Version |
| EvPlaceholderService.exe | 9.0.4.1097 | 9.0.4.1107 |
| evmf.sys (for 32 bit) | 9.0.4.1097 | 9.0.4.1107 |
| evmf.sys (for 64 bit) | 9.0.4.1097 | 9.0.4.1107 |
How to Install this hotfix:
On the File Server:
1. Stop the Enterprise Vault File Placeholder Service.
2. Go to the command prompt and run the following command as administrator:
3. Once Enterprise Vault File Placeholder Service has stopped, take a backup copy of file EvPlaceholderService.exe, located in the Enterprise Vault installation folder (which by default is C:\Program Files\Enterprise Vault, or C:\Program Files (x86)\Enterprise Vault on a 64-bit machine).
4. Once evfilter driver is unloaded, take a backup copy of file evmf.sys which is located in C:\Windows\System32\drivers folder.
5. Copy the updated file evmf.sys, packaged in this hotfix, to the C:\Windows\System32\drivers folder, replacing the original. For 32 bit file system, copy evmf.sys from 32bit folder and for 64 bit file system, copy evmf.sys from 64bit folder.
6. Copy the updated file EvPlaceHolderService.exe, packaged in this hotfix, to the Enterprise Vault installation folder (which by default is C:\Program Files\Enterprise Vault, or C:\Program Files (x86)\Enterprise Vault on a 64-bit machine) replacing the original.
7. Go to the command prompt and run the following command as administrator:
8. Start the Enterprise Vault File Placeholder Service.
How to Uninstall this hotfix:
1. Stop the Enterprise Vault File Placeholder Service on File Server.
2. Go to the command prompt and run the following command as administrator
3. Take the backed up copy of the files listed in the Which files does this hotfix replace? section and replace the hotfixed files, located in the Enterprise Vault installation folder(which by default is C:\Program Files\Enterprise Vault, or C:\Program Files (x86)\Enterprise Vault on a 64-bit machine) and C:\Windows\System32\drivers.
4. Go to the command prompt and run the following command as administrator
5. Start Enterprise Vault File Placeholder Service.
Attachments
|
|
|
| Source | ETrack |
| Value | 2804765 |
| Description | File server unresponsive in a hung state following PH recall. Reset required |
Article URL http://www.symantec.com/docs/TECH197715
Terms of use for this information are found in Legal Notices









Thank you.