Error fills the logs - IP Freq module: DB open failed: memory mapping error.

Article:TECH198258  |  Created: 2012-10-11  |  Updated: 2013-05-31  |  Article URL http://www.symantec.com/docs/TECH198258
Article Type
Technical Solution


Environment

Issue



You notice many iterations of errors in the logs, most of which refer to the IP Freq module. The SMG appliance may suffer from slow mail delivery as well as an increase in queue size.


Error



The first errors that are usually seen, and are a good indication of a beginning problem, are found in the Brightmail Engine (bmserver) log:

2012-09-27T02:44:59-05:00 (ERROR:17944.2756279184): [47018] IP Freq module: failed to update sender reputation record.
2012-09-27T02:44:59-05:00 (ERROR:17944.2756279184): [47005] IP Freq module: failure in post_process.
2012-09-27T02:46:52-05:00 (ERROR:17944.2955586448): [47016] IP Freq module: failed to ensure creation of sender reputation DB.
2012-09-27T02:46:52-05:00 (ERROR:17944.2955586448): [27051] init_modules: error while calling init function for module libipfreq.
2012-09-27T04:10:52-05:00 (ERROR:17944.2955586448): [47022] IP Freq module: DB open failed: memory mapping error.

 

Other related errors that are often involved with this situation:

[27224] An error occurred while decomposing a message.
[10001] Malloc error while attempting to allocate 7908031 bytes.
[10004] File write error.
[27224] An error occurred while decomposing a message.
[10001] Malloc error while attempting to allocate 3240493 bytes.
[10004] File write error.
[27224] An error occurred while decomposing a message.
[10004] File write error.

And sometimes:

DoXMPIteratePacket(): Exception id=201    msg=XML parsing failure
KVSAGetXMPMetadata(): KVERR Out of Memory!
Unknown Error Caught
*** glibc detected *** /data/scanner/rules/verity/kvoop: free(): corrupted 
unsorted chunks: 0x09efcba0 ***
*** glibc detected *** /data/scanner/rules/verity/kvoop: free(): corrupted 
unsorted chunks: 0x094d10a8 ***
*** glibc detected *** /data/scanner/rules/verity/kvoop: malloc(): memory 
corruption: 0x09d35a00 ***, but they are often related to bmserver memory issues.

As well as signal 6 and/or signal 11 process (typically mta or bmserver) crashes. Please note that there can be other reasons for these errors as well, so further investigation may be necessary.


Cause



This issue usually occurs due to the Symantec Messaging Gateway becoming overburdened due to mail flow and/or the amount of custom filtering being applied to that mail flow. When the amount of custom filtering and mail flow produces this issue, the result generally generates various error messages and increases the outbound and/or inbound queues.


Solution



This issue has been addressed in Symantec Messaging Gateway version 10.0.2. Please upgrade to take advantage of memory management and process control updates.

Other steps to help correct this issue, or for versions prior to 10.0.2:

  1. Configure "maximum message size in bytes" to be as small as needed for the environment (default 10485760): KB TECH91043.
  2. Enable Large Message Throttling: (Contact Symantec Technical Support for steps to enable this feature.)
  3. Reduce the number of content filtering policies.
  4. Add action of "Bypass all compliance" filters to the SPAM rule (Note: be sure you don't have a conflicting Bypass Spam rule in content filters, or messages will be fully bypassed - TECH196802.)
  5. Utilize the "Subsequent Content Filter Handling" feature of Content Filtering rules for appropriate filters to short-circuit further message processing.
  6. Add additional scanners to help distribute message load.

Immediate correction of the problem if it is occurring is to restart the Mail Transfer Agent and the Brightmail Engine using the following CLI command when logged into the command line using the admin account:

service mta restart

Symantec continually works to increase the capabilities of the Symantec Messaging Gateway. Subscribe to this document to keep updated.


Supplemental Materials

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Article URL http://www.symantec.com/docs/TECH198258


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