KNOWN ISSUE: ITMS 7.1.2 MP1 - Failed to load resource associations. [The user does not have permission to perform this action.]
| Article:TECH198556 | | | Created: 2012-10-18 | | | Updated: 2012-11-09 | | | Article URL http://www.symantec.com/docs/TECH198556 |
Problem
After upgrade to MP1 number of actions result in error Failed to load resource associations. [The user does not have permission to perform this action.]
Similar errors reported in SMP logs.
Error
Failed to load resource associations. [The user does not have permission to perform this action.]
( Exception Details: Altiris.NS.Exceptions.AeXUnauthorizedAccessException: The
current user does not have required permission 'read' to load item 'e1ad1230-
cadf-4a60-b382-9955bcbd0fec'.
at Altiris.NS.ItemManagement.Item.RaiseItemLoadFlagsSecurityException(String
message)
at Altiris.NS.ItemManagement.Item.CheckCanGetItem(IItem item, IEnumerable`1
accessPermissions, ItemLoadFlags itemLoadFlags)
at Altiris.NS.ItemManagement.Item.GetItemInternal(Guid itemGuid,
IEnumerable`1 accessPermissions, ItemLoadFlags itemLoadFlags)
at Altiris.NS.ItemManagement.Item.GetItem[T](Guid itemGuid, IEnumerable`1
accessPermissions, ItemLoadFlags itemLoadFlags)
at Altiris.NS.ItemManagement.Item.GetItem[T](Guid itemGuid)
at Altiris.NS.ItemManagement.Item.GetItem(Guid itemGuid)
at Altiris.NS.StandardItems.Product.ProductInstallation.InstallProduct()
at Altiris.Reporting.ReportingInstallation.InstallProduct()
at
Altiris.NS.Installation.ProductConfigurationWorker.ConfigureProductInternal
(String configFile, Boolean ownsProgressContext, SerializationMode
serializationMode) )
Environment
Symantec Management Platform 7.1 SP2 MP1
Cause
New stored procedure requires sysadmin rights for SQL server to access one of the system tables.
Solution
This issue has been reported to Symantec Developement Team. This issue has been fixed in the ITMS 7.1 SP2 MP1.1 Release. See DOC5955.
For customers that have not installed ITMS 7.1 SP2 MP1 yet, please refer to TECH197966 "Upgrading to ITMS 7.1 SP2 – MP1.1 – Best Practices"
For those customers that already upgraded to ITMS 7.1 SP2 MP1, please upgrade to ITMS 7.1 SP2 MP1.1 using SIM.
This was the previous workaround for those customers that already upgraded to ITMS 7.1 SP2 MP1 prior to the 7.1 SP2 MP1.1 release:
please use the following steps to fix the issue:
1. Elevate the SQL permissions using the following query (or grant SysAdmin rights to your account):
GRANT view server state TO AltirisServiceLoginNameHere --usually the AppID account name
2. On the SMP server, run from the command prompt (from the "...\Program Files\Altiris\Notification Server\Bin" directory):
aexconfig.exe /configureall
3. After the configuration completes, apply the updated Stored Procedure attached to this KB. See attached "spResourceAssociationsLoadData_mp1-fixed.sql"
4. Run the following SQL commands to clear previous stored procedure cached records:
dbcc freeproccache
dbcc dropcleanbuffers
5. Revert the SQL permissions if desired by running this query (or remove the SysAdmin rights if those were given):
REVOKE view server state TO AltirisServiceLoginNameHere
6. Run to the same scenarios where you were getting these permissions errors to validate if the issue is still present or not. If you still see those, restore the database from prior to the upgrade and run the steps above one more time.
| Source | ETrack |
| Value | 2964501, 2965187, 2965265 |
Article URL http://www.symantec.com/docs/TECH198556
Terms of use for this information are found in Legal Notices









Thank you.