Error "Analysis Server 'server name' does not exist." occurs when trying to configure IT Analytics

Article:TECH198904  |  Created: 2012-10-24  |  Updated: 2014-02-06  |  Article URL http://www.symantec.com/docs/TECH198904
Article Type
Technical Solution


Issue



When trying to enter the name of the Analysis Server (SSAS) into the IT Analytics Configuration page, the error "Analysis Sever 'server name' does not exist." occurs, where 'server name' is the expected name of the server that has SSAS installed and working.


Error



Analysis Server 'server name' does not exist.


Cause



The SSAS does not exist or the Symantec Management Platform Server (SMP) is unable to access the SSAS on the network.


Solution



IT Analytics requires an SSAS to function, along with a Microsoft SQL Reporting Server (SSRS). If the user has not yet set these up, they must be installed, configured and working before trying to use IT Analytic with them. Please Note: Symantec Technical Support is unable to assist the user in installing or troubleshooting their Microsoft SSAS or SSRS environment. If the user needs guidance on setting these up, please refer to your DBA or Microsoft for implementation assistance with Microsoft products, as these are not part of Altiris or IT Analytics but are a required pre-requisite.

Use the following troubleshooting steps to help determine what the issue is, where:
 

  1. Verify that the server name being used is correct. This is the computer name of the server running SSAS, which may or may not be the SQL Sever name used for the SMP. Try using its hostname, FQDN or IP address as tests to see if any of these three types will enable the connection to work. If not, in a Command Prompt from the SMP, use Ping and NSLookup to verify if it can access the SSAS:

    ping server_name
    nslookup server_name

    Do these timeout or outright fail? If so, then either the name is invalid or the SMP cannot access the server across the network. Contact your DBA or Network Administrator for assistance.
     
  2. Is the SSAS in an instance? If so, this must be specified in the name as server name\instance name. If you are unsure, contact your DBA for assistance.
  3. Is SSAS even installed? On the SQL Server were it is expected to be installed to, log into the Analysis Server. Is this option present or do issues occur? If so, contact your DBA for assistance.
  4. Are SQL and SSAS Windows services started? On the SSAS, go to the Windows Start button > Administrative Tools > Services, then review the SQL services there, specifically SQL Server (MSSQLSERVER) and SQL Server Analysis Services (MSSQLSERVER). Start these if they are stopped, if they are started already, restart them. Warning: Changing Widows services may have a negative impact on databases, such as Altiris, that use them. Consult with your DBA before making changes to these to ensure the production environment is not interrupted.
  5. Can anything other than IT Analytics access the SSAS? For example, can Excel? If not, contact your DBA or Microsoft for assistance. Information on how to do this can be found on Microsoft's web site:

    http://msdn.microsoft.com/en-us/sql10r2byfbi-trainingcourse_sql10r2byfbi07_unit.aspx
     
  6. Ensure that the Application Identity account has sysadmin privileges on the Analysis Service.


Related Articles

Error "Analysis Server 'servername\instance' does not exist" occurs when clicking on the Verify Connection button in IT Analytics when ports 2382 and 2383 are blocked
http://www.symantec.com/business/support/index?page=content&id=TECH175740

Error "The remote name could not be resolved" occurs when trying to access IT Analyics Configuration
http://www.symantec.com/business/support/index?page=content&id=TECH186827

How to install, configure and troubleshoot IT Analytics
http://www.symantec.com/business/support/index?page=content&id=HOWTO39470




Article URL http://www.symantec.com/docs/TECH198904


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