Error Migrating Helpdesk 6.5 KB Articles to Servicedesk 7.5 - System.ArgumentNullException: Value cannot be null. Parameter name: host at System.Net.Sockets.Socket.Connect(String host, Int32 port)
| Article:TECH199272 | | | Created: 2012-11-01 | | | Updated: 2012-11-16 | | | Article URL http://www.symantec.com/docs/TECH199272 |
Problem
When running the Migrate Helpdesk Articles tool to migrate Helpdesk 6.5 Knowledgebase articles to Servicedesk 7.5, as soon as the migration begins, an error is displayed.
Error
current component Start Email(SendEmailComponent)
System.Exception: Execution Engine Exception ---> System.Exception: Execution Exception ---> System.ArgumentNullException: Value cannot be null. Parameter name: host at System.Net.Sockets.Socket.Connect(String host, Int32 port) at LogicBase.Components.Default.Communication.SmtpClient2.GetClientDomain(String targetAddress) at LogicBase.Components.Default.Communication.SmtpClient2..ctor(String host, Int32 port) at LogicBase.Components.Default.Communication.SendEmailComponent.Run(IData data) at LogicBase.Core.ExecutionEngine.SinglePathProcessComponentExecutionDelegate.Execute(IData data, IOrchestrationComponent comp, String& outputPath, IExecutionEngine engine, TLExecutionContext context) at LogicBase.Core.ExecutionEngine.AbstractExecutionEngine.RunComponent(TLExecutionContext context, IData data, IOrchestrationComponent comp) --- End of inner exception stack trace --- at LogicBase.Core.ExecutionEngine.AbstractExecutionEngine.RunEngine(List`1 executionQueue)
Environment
Servicedesk 7.5
Cause
There were 3 Send Email Components that were improperly referencing application profile information.
Solution
The attached file contains 2 installers that should be run to resolve the problem.
1. Download the attached file to your Servicedesk server.
2. Extract the files to a folder.
3. Execute the files. Order is not critical.
4. Your fix is now in place.
Attachments
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Article URL http://www.symantec.com/docs/TECH199272
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