CMDB task "Inventory Clean Up" does not change computers to be unmanaged
| Article:TECH199402 | | | Created: 2012-11-06 | | | Updated: 2013-03-15 | | | Article URL http://www.symantec.com/docs/TECH199402 |
Problem
When running the CMDB task "Inventory Clean Up", it may not change computers to be unmanaged, based on the computer's specified Status for the task. This is verified by checking the database, such as the vAssetResource view, to see that computers in question are still set to IsManaged = 1 (managed).
Cause
Computers are in a working blacklist, or, are in a corrupted blacklist (defect, Core Etrack 2150266).
Solution
Background
This article discusses two scenarios from the Core blacklist functionality. One is working as designed, the other is a defect.
Please note that any Altiris product that processes or interacts with computers/clients can be affected by these two scenarios, including CMDB Solution and SEP-IC. As these blacklist scenarios are entirely controlled by Core, other Altiris products have no control over whether their tasks work or not with blacklists based on the information listed here.
Scenario 1: The computers are in a working blacklist. Computers in a blacklist are not expected to be processed by tasks. Resolve the issue why the computer is in the blacklist, and once they are removed, they should be able to be processed by tasks again.
Scenario 2: The computers are in a corrupted blacklist. Along with the fact that the computers have to be removed from the blacklist (scenario 1), a corrupted blacklist will result in other task processing issues. This is categorized as a defect, and is scheduled to be resolved by a future version of the Symantec Management Platform.
One way to tell if a blacklist is corrupted is to review the blacklist report and compare the number of computers in the black list by using a SQL script, for example:
USE Symantec_CMDB
SELECT *
FROM AgentBlacklist
If the number of records are different, for example, only a few are in the report but many are in the table, then the blacklist is indeed corrupted, as these should be the same number.
A workaround for this defect is to truncate the AgentBlacklist table. The following SQL script demonstrates how to do this:
TRUNCATE TABLE AgentBlacklist
Note: If the computers on the blacklist are still resulting in blacklisted behavior, they will be re-added to the blacklist later. Then, scenario 1 or 2 may re-apply. If so, resolve the issue why the computer is blacklisted.
After the AgentBlacklist table is truncated, re-try the problem task in question, such as the CMDB Inventory Clean Up task. Notes: (1) For Inventory Clean Up, if Symantec Management Platform Agents are still on the computers, when these check in next, they will change the status of the computer back to Active and IsManaged back to 1. This is working as designed. Computers that are required to be no longer on the network should be removed first before trying to set their IsManaged value with the CMDB task Inventory Clean Up. (2) In some cases, most but not all computers are then processed correctly by the task/process. Those that are not may only be a few. To correct these, delete them manually using Manage > Home > Configuration Items > Computers and Peripherals > Computer (CMDB Solution).
Related Article
How to use the CMDB task "Inventory Clean Up" with a filter
http://www.symantec.com/business/support/index?page=content&id=HOWTO83930
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Article URL http://www.symantec.com/docs/TECH199402
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