Enterprise Vault Exchange archiving tasks fail on startup when targeting Exchange 2013 in a mixed Exchange 2010/2013 environment

Article:TECH199616  |  Created: 2012-11-12  |  Updated: 2013-01-18  |  Article URL http://www.symantec.com/docs/TECH199616
Article Type
Technical Solution


Problem



Enterprise Vault Exchange archiving tasks fail on startup when targeting Exchange 2013 in a mixed Exchange 2010/2013 environment.


Cause



This occurs when all the following conditions are true:

 

  • Exchange 2013 and Exchange 2010 SP3 coexist in your environment
  • The Enterprise Vault system mailbox exists in an Exchange 2013 mailbox database which has RpcClientAccessServer set to a 2010 CAS server
  • The Vault Service account's mailbox is on an Exchange 2010 mailbox server

 

Although RpcClientAccessServer is not used by Exchange 2013 it can affect users with mailboxes on Exchange 2010.

 

You can use the following PowerShell cmdlet to check the current setting for RpcClientAccessServer:

 

Get-MailboxDatabase -Identity mailbox_database_name | fl RpcClientAccessServer


 


Solution



To rectify this issue, you can move the Vault Service account's mailbox to an Exchange 2013 server, or use the following procedure to set RpcClientAccessServer to an Exchange 2013 mailbox server.

 

To set RpcClientAccessServer to an Exchange 2013 mailbox server:

 

  1. On an Exchange 2010 server, open the Exchange Management Shell.
  2. Run the following command:

    Set-MailboxDatabase -Identity mailbox_database_name -RpcClientAccessServer exchange_2013_server

 

Where exchange_2013_server is the fully qualified domain name of the Exchange mailbox server that hosts the mailbox database.

 




Article URL http://www.symantec.com/docs/TECH199616


Terms of use for this information are found in Legal Notices