Backup to Tape Device not working with Backup Exec User Mode Driver

Article:TECH200261  |  Created: 2012-11-29  |  Updated: 2012-11-29  |  Article URL http://www.symantec.com/docs/TECH200261
Article Type
Technical Solution

Product(s)

Issue



Backup to Tape Device not working with Backup Exec User Mode Driver.


Error



Event:        67  Start:  9:44:51.595  Stop:   9:44:51.595  Duration:  0.000000
SCSI Address: 04:00:00:00
Function                                SRB_FUNCTION_EXECUTE_SCSI
SRB Status                              SRB_STATUS_DATA_OVERRUN | SRB_STATUS_QUEUE_FROZEN
SCSI Status                             SCSISTAT_GOOD
Flags                                   SRB_FLAGS_DISABLE_SYNCH_TRANSFER
 |                                      SRB_FLAGS_DATA_IN
Sense Length                            18
Data Length                             74
Driver Result                           STATUS_BUFFER_OVERFLOW

Raw CDB
12 00 00 00 FC 00                               ......

CDB Operation                           INQUIRY
 LUN                                    0
 EVPD                                   False
 Page                                   0
 Alloc Length                           252
 Control                                0x00
Data
01 80 05 22 45 00 00 02 51 55 41 4E 54 55 4D 20 ..."E...QUANTUM
55 4C 54 52 49 55 4D 20 34 20 20 20 20 20 20 20 ULTRIUM 4  


Environment



Quantum Ultrium 4 Tape Drive
Controller - LSI Adapter, SAS 3000 series, 4-port with 1064E -StorPort
Fujitsu D2616
Compatible : http://www.symantec.com/business/support/index?page=content&id=TECH70907


Cause



UMD Drivers are less resilient to Issues that may arise in the SCSI and hence the device might work when KMD Drivers are Installed. But it is recommended to use UMD Driver because of the below reason.

Note:  Any device using KMD will not be able to perform HW encryption or use the Big Blocksize (Read or Write) feature. This is not an issue as none of the devices supported by the legacy KMD had hardware support for these features in any case.


Solution



Install latest storeport fix from microsoft http://support.microsoft.com/kb/935640 and backup should work with Symantec User Mode Drivers. This fix is applicable to windows 2003 systems.

It is recommended to review the following log for hardware related Issues :

adamm log : http://www.symantec.com/docs/TECH89750
discover log : http://www.symantec.com/docs/TECH87501
tracer log : http://www.symantec.com/docs/TECH49432

Other Important Links :

http://msdn.microsoft.com/en-us/library/windows/hardware/ff567541(v=vs.85).aspx
http://msdn.microsoft.com/en-us/library/windows/hardware/ff565393(v=vs.85).aspx
http://msdn.microsoft.com/en-us/library/windows/hardware/ff567565(v=vs.85).aspx





Article URL http://www.symantec.com/docs/TECH200261


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