Exchange 2013 items with attachments archived via the Content Management API cannot be exported to PST using Discovery Accelerator, or viewed in Outlook using Archive Explorer

Article:TECH200516  |  Created: 2012-12-05  |  Updated: 2013-01-18  |  Article URL http://www.symantec.com/docs/TECH200516
Article Type
Technical Solution


Issue



Exchange 2013 messages that contain attachments and are imported into archives using the Enterprise Vault Content Management API (such as third party migration applications) may exhibit the following issues:

 

  • They cannot be exported to PST using Discovery Accelerator
  • They cannot be viewed in Outlook using Archive Explorer

Error



The following errors are written to the Symantec Enterprise Vault event log on the Discovery Accelerator server:

Log Name:      Symantec Enterprise Vault
Source:        Accelerator Service Processor
Date:          19/12/2012 14:27:26
Event ID:      236
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Mail2-KWDA01.mail2.lab
Description:
APP AT - Customer ID: 3 - [ExportPST] - Error moving some messages to PST for run 'ItemAttach (7)' : System.ApplicationException: Error in the application.
   at KVS.Accelerator.Production.ProductionQueue.ProductionRunQueue.HooverUpMsgsToPst()
   at KVS.Accelerator.Production.ProductionQueue.ProductionRunQueue.ScanProductionItemQueue()

Log Name:      Symantec Enterprise Vault
Source:        Accelerator Service Processor
Date:          19/12/2012 14:32:32
Event ID:      236
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Mail2-KWDA01.mail2.lab
Description:
APP AT - Customer ID: 3 - [ExportPST] - Error moving some messages to PST for run 'ItemAttach (7)' : System.ApplicationException: Failed to move some items from 'Failed Items' to 'Messages' folder
   at KVS.Accelerator.Production.ProductionQueue.ProductionRunQueue.ScanProductionItemQueue()

 

End users viewing items with Archive Explorer see the following error:
 

 

End-user error


Cause



Messages with attachments saved from Exchange 2013 as .MSG files have an additional property on the attachment table. The Outlook PST provider cannot handle this property and fails to copy the items into a PST.

 

This is a known Exchange 2013 issue.


Solution



A registry value is available to resolve these issues. 

 

Note: Setting the registry value impacts all recalls of Exchange items through the Storage service, adding a small overhead for each item. Therefore you should create the registry value only when you see the above issues in relation to Exchange 2013 items archived via third party applications.  Items archived by the Enterprise Vault archiving tasks or PST Import are not affected by this issue.

 

To set the registry value

 

  1. On all the Enterprise Vault machines that host a Storage service, create a new registry DWORD value called “FixExchange2013Attachments” under the following registry key:

    \HKEY_LOCAL_MACHINE\Software\Wow6432Node\KVS\Enterprise Vault\Storage
     
  2. Set “FixExchange2013Attachments” to 1 to enable the fix (set to 0 or delete the registry value disables the fix).
     
  3. Restart the Storage service.

 




Article URL http://www.symantec.com/docs/TECH200516


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