"Failed to authenticate via LDAP: [#320000] Cant connect to LDAP server. " after upgrading clearwell
| Article:TECH200642 | | | Created: 2012-12-07 | | | Updated: 2012-12-10 | | | Article URL http://www.symantec.com/docs/TECH200642 |
Problem
After upgrading from one Clearwell version to the next ldaps may nolonger work.
It may appear as if configuration settings are in tact and have not changed. Still ldaps authentication nolonger works.
The results of "LDAP Configuration Tester" is failing
Error
--- Results of test connection ---
----------------------------------
Failed to authenticate via LDAP: [#320000] Cant connect to LDAP server.
com.teneo.esa.common.exception.TeneoException: [#320000] Cant connect to LDAP server.
at com.teneo.esa.ui.auth.LDAP.authenticate(LDAP.java:264)
at com.teneo.esa.system.support.ldap.LdapConfig.runFeature(LdapConfig.java:135)
at com.teneo.esa.system.support.ProviderSupport._runFeature(ProviderSupport.java:259)
at com.teneo.esa.system.support.ProviderSupport.runFeature(ProviderSupport.java:202)
at com.teneo.esa.system.support.Support.runService(Support.java:299)
at com.teneo.esa.admin.service.AbstractService.run(AbstractService.java:1142)
at java.lang.Thread.run(Thread.java:662)
Caused by: org.apache.catalina.LifecycleException: Failed to start component [Realm[JNDIRealm]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:154)
at com.teneo.esa.ui.auth.LDAP.authenticate(LDAP.java:233)
at com.teneo.esa.ui.auth.LDAP.authenticate(LDAP.java:260)
... 6 more
Caused by: org.apache.catalina.LifecycleException: Exception opening directory server connection
at org.apache.catalina.realm.JNDIRealm.startInternal(JNDIRealm.java:2200)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
... 8 more
catalina log show something like:
javax.naming.CommunicationException: simple bind failed: uspto.gov:636 [Root exception is javax.net.ssl.SSLException: Connection has been shutdown: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target]
at com.sun.jndi.ldap.LdapClient.authenticate(LdapClient.java:195)
at com.sun.jndi.ldap.LdapCtx.connect(LdapCtx.java:2720)
at com.sun.jndi.ldap.LdapCtx.<init>(LdapCtx.java:296)
at com.sun.jndi.ldap.LdapCtxFactory.getUsingURL(LdapCtxFactory.java:175)
at com.sun.jndi.ldap.LdapCtxFactory.getUsingURLs(LdapCtxFactory.java:193)
Cause
This may be caused by a number of reasons.
The upgrade may not have moved the "cacerts" file from the previously working jrockit location to the new jrockit version location.
Solution
Contact Tech support.
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Article URL http://www.symantec.com/docs/TECH200642
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